Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an external USB drive that was working just fine, and then the internal SATA drive on my PC crashed. After replacing the internal drive, upgrading the processor, and reinstalling Windows 7, I plugged the USB drive back in, and below is what I got. Update: for clarity, when I try to access the drive, I get an "access denied" error message.

I downloaded the Seagate tools and ran all the tests, which passed. I also found a forum post indicating that chkdisk can be used to force a USB drive eject, which I also tried. It ejected, but then after disconnecting and reconnecting, I got the same result.

What can I do?

enter image description here

Update:

enter image description here

share|improve this question
add comment

4 Answers 4

Try opening it anyway, the icon may just be corrupted in the icon cache and the drive perfectly fine.

share|improve this answer
    
No, it doesn't work. I just didn't post the screenshot, but the error is "Access Denied". –  Ben Collins Jan 12 '13 at 23:01
add comment

Try typing takeown /r G:\* at the command line.

*the /r makes it recursive [apply to subdirectories also]

For more info see Microsoft's Technet website:

[Takeown] enables an administrator to recover access to a file that previously was denied, by making the administrator the owner of the file.

share|improve this answer
1  
I was able to access the drive on another PC. Does this change how I should deal with it on the PC where I can't get to it? –  Ben Collins Jan 13 '13 at 3:23
    
I tried it, and got ERROR: Access is denied –  Ben Collins Jan 13 '13 at 3:28
    
did you run cmd as an administrator? to do so, go to start, type in cmd, right-click it and click "Run as administrator". –  Jakob Weisblat Jan 13 '13 at 16:06
add comment

Try to check it in another pc, or just boot from any linux live-cd (Ubuntu f.e.) to check usb health in real situation. Also maybe BIOS resetting can solve the problem.

share|improve this answer
add comment
up vote 0 down vote accepted

Looks like it was a matter of ownership. When I replaced my disk and reinstalled Windows, my user had a new Sid, so despite having the same username as before, to Windows, it looked like some other unknown user owned the drive and therefore denied me access. Once I changed ownership of the drive at the files on it, I was able to regain access.

Here's a step-by-step reference for anyone with the same issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.