Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I updated Java 7 Update 9 (Which was working fine) to Java 7 Update 10, and now I can't use Java in my Google Chrome browser, I get the error message "Java(TM) is required to view some elements on this page.", I have tried uninstalling java multiple times and no matter what I still get this error.

I've tried installing Java from the dialog on the page page with the Java applet, I've tried installing the offline version, and the online installer version, but still I end up with that message as a result.

It works in Internet Explorer 10, and I have confirmed that Java is enabled in browser in the Java Control Panel, and I have Java 32 bit and 64 bit installed and have checked both control panels and they both have Java enabled.

It didn't work in Windows 7, and I have Upgraded to Windows 8 recently and it still doesn't work.

I have checked in chrome://plugins to confirm that Java is not disable there, and I notice that the path of the plugin is "C:\WINDOWS\SysWOW64\npDeployJava1.dll", since Chrome is a 32bit browser shouldn't this be the npDeployJava1 in System32, not the one in SysWOW64?

If this is the problem how would I change it?

My version of Chrome is: 24.0.1312.52 if that helps.(Didn't work in version 23 either.)

Also I have tried to uninstall all the Java's and re-install Google Chrome and then re-install Java again (Just the 32-bit version at first) and it did not help.

share|improve this question
1  
System32 is where the 64-bit stuff is, on 64-bit versions of Windows. It's for backwards compatibility. –  ta.speot.is Jan 12 '13 at 4:06
add comment

1 Answer 1

Open your command prompt and try typing

java -version

If you receive an error that the command is not found then it could be a path issue.

Navigate to the Java BIN directory

c:\program files\java\jre7\bin

or

c:\program files (x86)\java\jre7\bin

and then try typing java -version again. If you get a version number back then you know that this is the issue. Copy the path to the BIN folder and add it to your Environment Variables.

Restart and it should work fine. However, if you cannot restart that machine, you can copy the entire Environment Variables text and type set path=XXX where XXX is the full variable.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.