Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Five minutes ago I was browsing my external hard drive. Now, I have only one folder named "found.000" that I cannot read, open nor browse. I have important work on my external hard drive. Is there a way to retrieve my data?

I was trying to use TestDisk but I do not know how to use it very well and I don't know the type of partition there is on my external hard drive (Toshiba Stor.E Canvio - 500Gb) this is what the log says :

Disk /dev/rdisk2 - 500 GB / 465 GiB - 976773168 sectors (RO)                    
Current partition structure:                                                    
     Partition                  Start        End    Size in sectors             

Warning: number of heads/cylinder mismatches 255 (NTFS) != 1 (HD)               
Warning: number of sectors per track mismatches 63 (NTFS) != 1 (HD)             
 1 P HPFS - NTFS                 2048  976771119  976769072 [TOSHIBA EXT]       

Warning: Bad starting sector (CHS and LBA don't match)                          
No partition is bootable                                                        

0 D FAT32 715093261 1896786745 1181693485 
FAT32 715093261 1896786745 1181693485 
check_FAT: can't read FAT boot sector 
Invalid FAT boot sector 
0 D FAT16 LBA 2125262773 5909813675 3784550903 
FAT16 LBA 2125262773 5909813675 3784550903 
check_FAT: can't read FAT boot sector 
Invalid FAT boot sector 
0 D FAT32 LBA 1365415759 2816414404 1450998646 
FAT32 LBA 1365415759 2816414404 1450998646 
check_FAT: can't read FAT boot sector 
Invalid FAT boot sector 
0 D FAT12 2873871126 2963834879 89963754 
FAT12 2873871126 2963834879 89963754 

I am using a macbook pro mid-2009, with Snow Leopard (Mac OX 10.6.8). I tried to retrieve my data with MacKeeper the disk is not readable. It is an NTFS disk.

Here are some screenshots from Testdisk.

enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here Thank you in advance.

share|improve this question

migrated from Jan 12 '13 at 11:29

This question came from our site for professional and enthusiast programmers.

First of all: umount this disk from macos (or remount in read only) because ntfs has a journal and in your case some data may be lost.

If this is ntfs, you should use something like GetDataBack for ntfs or Easy NTFS Data Recovery.

PS: using windows for this is a good idea.

share|improve this answer
They are using a Macbook its unlikely they have access to a Windows machine. – Ramhound Jan 13 '13 at 9:13
I know, that's why i add "using windows for this is a good idea." Moreover there are live CD's, which have recovery tools. But using some driver or 'plugin' for this is dangerously. – loadaverage Jan 13 '13 at 9:39
I dont have access to windows except at the university and the access is restricted. I have been able to recover data with Data Rescue but it is a mess... all the mp3 are in a same folder, documents have numbers instead of names. So I would like to be able to fix the drive if possible. – esmitex Jan 13 '13 at 11:02
I am looking for a software that would allow me to retrieve data like it was on the drive with the same folders etc because 10 000 files in one folder is messy. – esmitex Jan 13 '13 at 12:18
I have been able to recover the folder structure with Minitool Data Recovery for mac. – esmitex Jan 15 '13 at 11:16

Why not try Photorec?

It's by the same Company as Testdisk - but specifically for Multi-media files. It's also MAC friendly, and will just try and recover as many files as it can detect (over 300 different types)

It's also a bit easier to use than Testdisk!

share|improve this answer
I have used Photorec in the past and like Data rescue it recovered my data but there was no folder structure. It is not appealing to find out you have a folder full of pdf and .doc files renamed like 01101011.doc etc – esmitex Jan 14 '13 at 6:50

Easeus partition recovery may be able to do what you want if they make a MAC version as it recovers the actual partition structure... I've noticed MOST recovery programs tend to rename files with numbers unless they have a option to recover with the MBR and even then you're lucky if it does.

The first thing I would do is uninstall and reinstall the drive (preferably to at least a different usb port, if not a different computer)...

My BF was trying to install windows on a desktop computer and no matter how many times we said format and install it just wouldn't work. It saw the drive and didn't say there were any problems with it, but it turns out the IDE cable wasn't plugged in all the way so somehow it could detect it and supposedly format it successfully, but not actually touch it.

On failing externals we've had no files, or files with corrupted file names, but when we unplug them and plug them back in the files come back normal.

share|improve this answer
The drive is not failing. It was working fine, I bought it last month and it never fell and has never been hit. I have been able to recover my data with folder etc using Minitool Data Recovery. Though, I believe the drive can be fixed without losing data or formatting it with TestDisk. I just need to figure out how. – esmitex Jan 18 '13 at 12:39
brand new drives have been known to fail straight out of the box... they don't have to fall either... small electrical surges or brown outs can mess them up, but it is unlikely which is why I suggest uninstalling it or trying it in another computer... it could be your usb port or even a registry glitch... also try a different usb cord... if you don't feel like using the warranty you can also take it out of the enclosure and stick it directly into the computer to rule out any problems with the enclosure circuitry... to uninstall it rightclick safely remove and go to properties for the usb part – krazykat1980 Jan 18 '13 at 21:09

Connect the disk with windows PC (XP/Win7/Win8)

Open command prompt.(Run as administrator Mode) (Start Run , then type cmd and enter (Select the cmd.exe and right click run as administrator)) chkdsk [volume]: /[switch] /[switch] ... /[switch]

/F : Fixes errors on the volume. The volume must be locked. If CHKDSK cannot lock the volume, it offers to check it the next time the computer starts.

/R : Locates bad sectors and recovers readable information (implies /f and /p). Unreadable data is lost. If CHKDSK cannot lock the volume, it offers to check it the next time the computer starts.

Example: C:>chkdsk G: /f /r

It's done the same way in Windows 7 as it was in earlier versions of Windows: Open the "Computer" window Right-click on the drive in question Select the "Tools" tab In the Error-checking area, click .

share|improve this answer
I will try it when I have access to a pc. – esmitex Jan 25 '13 at 11:05
up vote 0 down vote accepted

I have been able to recover all my data with the folder structure with Minitool Data Recovery. I haven't tried to fix the geometry of the drive with TestDisk yet though.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .