Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

if I type

notepad Hi,java

I am getting an error as

notepad is not recognized as internal or external command

What is wrong here?

share|improve this question
add comment

1 Answer

Check how you path is defined.

E.g. start cmd.exe, then type echo %%path%%. It should include %windir%\system32.

enter image description here

If it is not in your path then add it. You can do this in several ways; the easiest is way probably via [My computer] right click [Properties] advanced system settings, tab [advanced], button [Environment variables]

Note that %windir%\system32\ is in the path by default. In order not to have it someone either removed it, or you or an installer set a new path replacing the old path. (Probably when you wanted to append to the path).

share|improve this answer
1  
You don't need two percent signs. echo %PATH% is enough. Or just path. –  utapyngo Jan 12 '13 at 15:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.