Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using x64 Linux Mint 13 (Maya), which is based on Ubuntu 12.04 (Precise). The current version of Thunderbird installed is 17.0.2. My goal is to archive my messages into custom folders that are a) separated by month, as shown:

Monthly archive folders

and b) stored in my Gmail account, not in the Local Folders are of Thunderbird. However, the Archive Options are greyed out unless I select Local Folders, as shown:

enter image description here

On a different system, one running Ubuntu 12.04 x32 itself (not a Linux Mint derivative) and running Thunderbird 17.0 (not 17.0.2) the Archive Options button is not greyed out and I can set monthly folders as an option. Archiving works properly, and the monthly folders are created automatically.

How can I archive my emails to these monthly folders in Thunderbird 17.0.2? Using Gmail's All Mail folder is not an option in Thunderbird because that folder in my gmail account has hundreds of thousands of emails, and enabling it in IMAP slows the program drastically.

share|improve this question

3 Answers 3

up vote 0 down vote accepted

From what I can tell, this is a Windows-only option. On various Windows systems, the option is not greyed out and archiving to monthly folders works properly. On various Linux systems, however, the option is either greyed out or doesn't function properly. Specifically, archiving to monthly folders simply places emails in the global archive without separating them by month.

share|improve this answer

From my understanding, this issue only affects Gmail accounts.

Here is an excerpt from the documentation discussing the issue:

In order to be consistent with Gmail's behavior, Thunderbird archives your message in the "All Mail" folder, and not in an "Archive" folder as it does for other accounts...

share|improve this answer

There is a config value called mail.identity.default.archive_granularity (or mail.identity.[id of account].archive_granularity) for the archive behaviour with these possible values :

  • 0 for none
  • 1 for year
  • 2 for year/month

See details in the New Archives Folder article on MozillaZine Knowledge Base.

You can set it manually in Edit > Preferences > Advanced > General tab > Config editor and then search for the specific key to set it to 2 in your case.

Maybe it will solve your problem.

share|improve this answer
    
In Thunderbird 24.6 (Arch Linux), I have id11 and id12. Both were already set to 1, so this option doesn't appear to work. –  Sparhawk Jul 15 at 23:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.