Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Ffmpeg sync error, first image showing really fast

I'm using Windows and FFmpeg for Windows.

My material are 8 images, with names like:

  • product0001img01.png
  • product0001img02.png
  • product0001img03.png
  • and so on

When I use KMPplayer or GOM, it's showing only product0001img02.png until product0001img08.png. I tried to upload it to YouTube, which gave me the same result.

But when playing it with KliteMegaCodec, all the images are loaded fine.

I use the following command:

ffmpeg -r 1/7 -i  "C:\Documents and Settings\admin\My Documents\Visual Studio 2008\Projects\WBAY\WBAY\bin\Debug\data\tempimages/product0001img%02d.png" -vcodec libx264 -y  "C:\Documents and Settings\admin\My Documents\Visual Studio 2008\Projects\WBAY\WBAY\bin\Debug\data\temp/product0001.mp4"

Here's the log:

ffmpeg version N-48228-gceee440 Copyright (c) 2000-2012 the FFmpeg developers
  built on Dec 27 2012 01:53:09 with gcc 4.7.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil      52. 12.100 / 52. 12.100
  libavcodec     54. 81.100 / 54. 81.100
  libavformat    54. 50.102 / 54. 50.102
  libavdevice    54.  3.102 / 54.  3.102
  libavfilter     3. 30.101 /  3. 30.101
  libswscale      2.  1.103 /  2.  1.103
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  2.100 / 52.  2.100
Input #0, image2, from 'C:\Documents and Settings\admin\My Documents\Visual Studio 2008\Projects\WBAYdevWITHSHORTENER\WBAY\bin\Debug\data\tempimages/product0001img%02d.png':
  Duration: 00:00:00.32, start: 0.000000, bitrate: N/A
    Stream #0:0: Video: png, rgba, 640x360, 25 fps, 25 tbr, 25 tbn, 25 tbc
[libx264 @ 02625020] using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.2
[libx264 @ 02625020] profile High, level 2.2
[libx264 @ 02625020] 264 - core 129 r2230 1cffe9f - H.264/MPEG-4 AVC codec - Copyleft 2003-2012 - http://www.videolan.org/x264.html - options: cabac=1 ref=3 deblock=1:0:0 analyse=0x3:0x113 me=hex subme=7 psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=1 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=6 lookahead_threads=1 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=3 b_pyramid=2 b_adapt=1 b_bias=0 direct=1 weightb=1 open_gop=0 weightp=2 keyint=250 keyint_min=1 scenecut=40 intra_refresh=0 rc_lookahead=40 rc=crf mbtree=1 crf=23.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
Output #0, mp4, to 'C:\Documents and Settings\admin\My Documents\Visual Studio 2008\Projects\WBAYdevWITHSHORTENER\WBAY\bin\Debug\data\temp/product0001.mp4':
  Metadata:
    encoder         : Lavf54.50.102
    Stream #0:0: Video: h264 ([33][0][0][0] / 0x0021), yuv420p, 640x360, q=-1--1, 16384 tbn, 0.14 tbc
Stream mapping:
  Stream #0:0 -> #0:0 (png -> libx264)
Press [q] to stop, [?] for help
frame=    8 fps=0.0 q=2292935.0 Lsize=     165kB time=00:00:42.00 bitrate=  32.1kbits/s    

video:164kB audio:0kB subtitle:0 global headers:0kB muxing overhead 0.501697%
[libx264 @ 02625020] frame I:2     Avg QP:15.47  size: 34494
[libx264 @ 02625020] frame P:6     Avg QP:15.49  size: 16319
[libx264 @ 02625020] mb I  I16..4: 39.6% 18.0% 42.3%
[libx264 @ 02625020] mb P  I16..4: 20.0% 10.7% 21.8%  P16..4:  5.3%  3.5%  2.9%  0.0%  0.0%    skip:35.7%
[libx264 @ 02625020] 8x8 transform intra:19.4% inter:28.2%
[libx264 @ 02625020] coded y,uvDC,uvAC intra: 54.8% 46.1% 38.8% inter: 13.4% 13.6% 10.4%
[libx264 @ 02625020] i16 v,h,dc,p: 82%  9%  5%  4%
[libx264 @ 02625020] i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 17% 30% 20%  5%  4%  3%  6%  5% 10%
[libx264 @ 02625020] i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 33% 28% 10%  4%  5%  5%  5%  4%  5%
[libx264 @ 02625020] i8c dc,h,v,p: 64% 20% 12%  4%
[libx264 @ 02625020] Weighted P-Frames: Y:0.0% UV:0.0%
[libx264 @ 02625020] ref P L0: 32.5%  5.5% 51.9% 10.1%
[libx264 @ 02625020] kb/s:23.84

Here youtube links YoutubeLinks

share|improve this question

marked as duplicate by slhck Jan 14 '13 at 7:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
If one player shows you all the images, they must be there. It could be a problem with B-pictures; try the command again with -profile:v baseline and see if that works for the other players, just as a test. Could you maybe upload a sample file for us somewhere? That'd be great. –  slhck Jan 12 '13 at 15:43
    
@slhck test with your command, but still not getting better... Here youtubelinks, and in case you might need the images fileimages –  radiaku Jan 12 '13 at 16:02
    
Thanks for the sample. All works fine for me, with product0001img%01d.png as the input – %02d throws an error about a non valid range. Can you try ffmpeg -pattern_type glob -i "product0001img*.png" -c:v libx264 output.mp4? –  slhck Jan 12 '13 at 16:13
    
@slhck getting error [image2 @ 0249f9a0] Pattern type 'glob' was selected but globbing is not support ed by this libavformat build C:\Documents and Settings\admin\My Documents\Visual Studio 2008\Projects\WBAY\WB AY\bin\Debug\data\tempimages/product0001img%02d.png: Function not implemented –  radiaku Jan 12 '13 at 18:28
    
Try with a more recent static Windows build, e.g. from Zeranoe: ffmpeg.zeranoe.com/builds — the globbing should be available in all recent FFmpeg versions. –  slhck Jan 12 '13 at 18:46

2 Answers 2

As mentioned by Karan, Its FFMPEG issue ( CMIW) FFmpeg is adding the first image to the video, just that the delay is so short it's not visible.

So I marking this as answers for my questions :)

share|improve this answer

If the end goal is to obtain a working mp4 from a series of images, an alternative to programming your own solution and using FFmpeg, you can use the free Windows Movie Maker (for Win7 and 8). The 2012 version (without the 'live" of the former version) outputs MP4 (for web and youtube) or AVI. It can convert a series of stills into a mp4. Once Movie Maker is installed, start a new project and add your PNG's. The default frame rate is 7 seconds per still image, but you can manually type in any value (.01 or greater). I was pleased to find this much easier and better quality than some of the other "images to video" conversion tools. (ImageMagick is another, similiar to FFmpeg).

share|improve this answer
    
I using C#, ffmpeg with process to build via commandline... Windows Live movie maker is GUI, :D –  radiaku Jan 12 '13 at 18:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.