Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My NVIDIA GT440 doesn't work with current Debian Squeeze - it shows only 1024x768 as max.

I did almost everything like

  1. xrandr
  2. xorg.conf (delete, creating etc.)
  3. download the NVIDIA driver from NV (doesn't work)
  4. objdump nouveau etc driver/libs (they're lookin ok)
  5. substituting the drivers/libs from SystemRescue CD to my installation
  6. using correct params for my LCD

What me wonders: On the SystemRescue the resolution eg. 1440x900 works - Wonder why??

Please could some Linux X11-Server Guru help me (I hope no compilation of nouveau is required) ;-)))

share|improve this question
1  
What do you mean by "download the NVIDIA driver from NV (won't work)"? That is probably your best option. –  terdon Jan 12 '13 at 18:28
    
Also, please post your xorg.conf. –  terdon Jan 12 '13 at 18:37
    
The Nvidia driver doesn't install (an already known problem) - even if I force it (maybe different version of libs). And for the Xorg.conf. I haven't anyone at first then I used this one: lists.debian.org/debian-amd64/2008/05/msg00154.html . It still doesn't work –  8ohmh Jan 15 '13 at 10:28
    
Just to share my own experience: When I used multiple solutions (apt installation and nvidia's own package), it turned out that some conflicts happened that I could not fix. Therefore, I reinstalled my debian and installed the driver from nvidia web site and it is working now (fresh install+closing the x completely). –  emab Nov 16 at 1:23

1 Answer 1

There are a few things you can try. First of all, as a general rule, if you choose an xorg.conf file from the depths of the internet, don't pick one that is posted on a thread about how the xorg.conf file is not working as expected :).

Try the following steps:

  1. Add your screen resolution to the xorg.conf file. The one you posted has no entry for 1440x900. Makes sure one of the "Modes" is "1440x900".

  2. Most of that xorg.conf file is irrelevant or just plain wrong for your hardware, try a barebones xorg.conf, something like:

    Section "Device"
        Identifier     "Device0"
        Driver         "nouveau"
        VendorName     "NVIDIA Corporation"
        BoardName      "NVIDIA GT440"
    EndSection
    
    Section "Screen"
        Identifier      "Screen0"
        Device          "Device0"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1440x900"
        EndSubSection
    EndSection
    
  3. Create an xorg.conf file for your system. Log out of your session, then press Ctrl+AltF1 to drop to a tty. Log in with your username and password, then do:

    sudo Xorg -configure
    

    That will create a new xorg.conf file saved as /root/xorg.conf.new. Copy that to /etc/X11/xorg.conf and resstart the X server.

  4. Make sure the correct drivers are loaded. If you are using the nouveau driver, run sudo modprobe nouveau.

  5. Try and install the nvidia driver again. Alternatively, post a new question with the error message you receive. The general procedure should be:

    sudo apt-get install module-assistant nvidia-kernel-common
    sudo m-a auto-install nvidia-kernel${VERSION}-source
    sudo apt-get install nvidia-kernel-dkms nvidia-settings nvidia-xconfig
    sudo nvidia-xconfig
    
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.