Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

See topic.

set guioptions?

guioptions=aegirLtmT

The normal tip is to delete ~/.gnome2/Vim, but this file doesn't exist.

The strange thing is that after installing some plugins, Plugin shows as a menu item.

Is my gvim installation on arch borked? I've tried reinstalling, but it doesn't help..

EDIT: Accepted answer is not what I did to solve the issue (see my comment to the answer), but would hopefully have worked.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

It appears @simendsjo is missing the file $VIMRUNTIME/menu.vim. I'd be happy to give him mine, but I would trust me as far as I could digitally throw me. You can download it from here though (it's a mirror ftp.vim.org) and place it in $VIMRUNTIME/.

I'm only creating a separate answer so others see it as the correct answer if in fact this fixes it.

share|improve this answer
    
I ended up continuing to uninstall everything vim and deleting all settings. This helped. I guess I f.. up when installing some through manual AUR, some through yaourt, and some manually copied from a windows disk :) –  simendsjo Jan 14 '13 at 19:33

I don't have the answer, but here is how I would approach the problem.

The first thing to try would be to start gvim from a shell like this:

gvim -u NONE

That should show you the menu bar and the tool bar. If you don't see both of those, perhaps your gvim was built without support for them, but that's doubtful. Execute

:version

and look for any feature names that begin with -, such as -menu.

It is suspicious that the order of flags in the 'guioptions' value you have shown differs from the default order. That suggests that something removed, then added flags during startup. That might have something to do with it. Restart gvim normally and xecute

:verbose set guioptions?

to see what touched that option last.

Something else you can try is to execute

:scriptnames

That will show you all the script files that gvim has sourced since startup. That might show you some suspicious files such as the ~/.gnome2/Vim you were looking for.

share|improve this answer
1  
This is excellent. One more place you should add for them to check is in $VIMRUNTIME/menu.vim. I ran gvim --version | grep menu and saw that in fact there is a +menu option and that path came up as the system menu file. So if his is compiles properly, he might just be missing the menu file. Inside of gvim he can determine the value of $VIMRUNTIME by doing :echo $VIMRUNTIME. –  sigmavirus24 Jan 12 '13 at 22:23
    
-u NONE doesn't show the menu. Without this option, the Plugins menu item appears. :version has both +menu and +toolbar. @sigmavirus24: I'm missing menu.vim - it doesn't appear even after reinstalling gvim. What to do... –  simendsjo Jan 13 '13 at 17:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.