Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just upgraded to Windows 8 (from XP) and re-installed my copy of Office 2007. Now the common shortcuts (Ctrl-Z, Ctrl-C, Ctrl-V etc) don't work in Word, however other shortcuts (Ctrl-P) are fine.

These shortcuts do work in other applications (such as Chrome) and they even work in other office applications (PowerPoint).

When I go into the customize shortcuts option in Word I see that EditPaste command has Shift-Insert shortcut and I can add Ctrl-V but I can't find Undo and Redo.

BTW I'm using a Hebrew version of Office (I don't know if this is relevant).


Note: The accepted answer was edited after I accepted it. I didn't check that the modified answer is correct so be aware that the original answer (and the one that solved my problem) was to do with the currently selected input language when Word was launched, not the default keyboard language.

share|improve this question
1  
It is a bug and happened to me. When you use dual input of languages then if word is opened and the default keyboard input language is not english, it messes all shortcuts making it difficult to change them all. Just change the default language (move up) to english, close Word 2013 and reopen it. Stupid bug. Hope they fix it soon. – dtakis Aug 16 '13 at 17:05
up vote 20 down vote accepted

At last after a lot of searching on the Internet I found the solution:

You must select English as the default keyboard language (control panel -> regional settings -> keyboard).

If you select a non-English language as the default keyboard language and open Microsoft Word a lot of shortcuts will change to IBM Common User Access mode (e.g. Ctrl+C will change to Ctrl+Ins and Ctrl+V will change to Shift+Ins)

Note that if you set English as the default keyboard language everything will still work even while you're switching your keyboard language to type non-English text.

This problem appears in all Office versions from 2003 to 2013. It also appears in all versions of Windows since Windows 2000 and at least with Hebrew, Greek and Arabic languages but I guess with many (all?) others as well.

Note: For Windows 10 the above option is found under Control Panel -> Clock, Language, and Region -> Change input methods (under Language) -> Advanced Settings (on the left) -> Override for default input method.

share|improve this answer
1  
That's amazing! How did you find this? – Motti Oct 14 '13 at 17:33
2  
You should signal this bug to Microsoft. – harrymc Oct 14 '13 at 19:02
    
I choose english-US keyboard, open word and have the same issue, so this is not the case for me. Problem lies in something else. – maks Dec 2 '13 at 22:45
1  
No, this answer does not solve the problem. – Dima Nov 28 '14 at 15:56
    
@Dima have you changed the default keyboard language or have you just switched the current keyboard language to English? Myself I missed this important detail the first time and I edited the answer to emphasize it. – ndemou Sep 28 '15 at 19:17

Go to Word options → Customize → Keyboard shortcuts (customize) → Categories → All commands.

At EditCopy or EditRedo or others Press new shortcut key and press Assign.

share|improve this answer
    
Or instead of reprogramming individual commands, click "Reset All" (within "Customize Keyboard window") - worked for me. I guess it has to do with installation of additional languages or specific programs that mess up the settings, thus - reset. --anonymous user – soandos Dec 5 '13 at 5:52
    
for Word 2010 see zoomicon.wordpress.com/2015/11/25/… – George Birbilis Nov 25 '15 at 2:51

Motti, I'm having the EXACT same issue with Hebrew Word 2010 and my newly installed Windows 8 (installed during the snow day!). When I went into the customized shortcuts, I chose to save these settings for THIS file (rather than for Normal, which always seems to give me trouble). Then it worked, and not just in that file!

share|improve this answer

The post Is it possible to make a custom shortcut to “undo” in Word 2013? has this answer (that I didn't test and in any case I don't have your version of Word):

  • Right click on the ribbon menu. Select Customize the Ribbon.
  • Select the Customize Ribbon category on the left side column.
  • Go to the right side column (main tabs) then select a tabs category of your choice (e.g. Home) and click on the New Group button
  • Use Rename to name it Undo Redo, then in the drop-down menu Choose commands on the left, select All commands.
  • Find the command named Undo and click on the button Add.
  • Do the same for the Redo command.
  • DON'T CLICK on the Customize button yet. Just hit the OK button of the window
  • Again right-click on the ribbon and select Customize the Ribbon.
  • Now you can click the Customize button next to the title Keyboard shortcuts, then select the Home tab (left column) and find the EditUndo command on the right column.
  • Select it and click on the text area under the "Press new shortcut key" title. Press Ctrl+Z on your keyboard and then click the assign button. Click the Close button on this window, then the OK button.
  • Do the same for the EditRedo command and assign the Ctrl+Y shortcut.

This answer can also be extended to other problematic shortcuts.

share|improve this answer
    
Sounds promising. I will check this today. – Adam Matan Mar 17 '13 at 6:27
    
Will do my best, still at work... – Adam Matan Mar 17 '13 at 14:17
1  
@AdamMatan I see you gave this answer a bounty, you may be interested to see the answer I just accepted which solves all shortcuts in a fell swoop. – Motti Oct 14 '13 at 17:35
    
@Motti: The answer you accepted means a bug in Word when started with a non-English keyboard and should be signaled to Microsoft. My solution is more cumbersome, but will work with all keyboards. – harrymc Oct 14 '13 at 19:02
    
@harrymc You're right, I will report this. – Motti Oct 14 '13 at 19:58

I see same problem with Windows 8 Ent & MS Word 2013 Ent.

I do following: 1. Regional settings - all needed settings for Bulgarian , Keyboard for English-US, Default input - English-US. 2. Install Proffing Tools for Bulgarian Language 3. Restart MS Word 2013

That's it - shortcuts work Ctrl-Z, Ctrl-C, Ctrl-V, Ctrl-X .

share|improve this answer
2  
how does language pack installation solve the ctrl shortcut keys – BlueBerry - Vignesh4303 Oct 8 '13 at 9:34

There is no solution but there are two workarounds. Both have their pros and cons:

Workaround #1 Set English as the system-wide default keyboard language.

  • For windows 7 go to Control Panel → Region and Languages → Keyboards and Languages → Change keyboard and set "Default Input Language" to English (the steps with screen-shots are here)
  • For Windows 10 go to Control Panel → Clock, Language, and Region → Language → Change input methods → Advanced Settings → Override for default input method and select English (screen-shot)

Note that from now on every time you start a new application the keyboard layout will switch to English.

Caution for users with non Latin characters in their passwords: Your login screen will also default to English and you should remember to switch layout before typing your password.

Workaround #2, Customize Word to recognize the short-cuts you use (one by one)

Go to Word options → Customize → Keyboard short-cuts (customize) → Categories → All commands. Select EditCopy, press Ctrl-C and click Assign. Repeat for EditPaste, EditUndo and any other action you want to fix.

share|improve this answer

Most probably, your version of Word has some "custom" shortcuts like that, overwriting basic stuff. Pretty weird that the basic Ctrl-C/V things won't work, but such problems aren't unheard of. For example, I do Ctrl-Alt-, for the character "<", but in Word, this is "font size down" or something like that, so I have to disable that shortcut or I can't type the character.

If you're looking for Undo and Redo, well, it's hard to say since they translate most things in the software, but in my French version, when looking at all commands in the shortcut customising dialog box, they were named "ÉditionAnnuler" and "ÉditionRétablir", which would be "EditUndo" and "EditRedo" in English, I guess. Look for whatever the usual "Edit" menu is in Hebrew and you should find it.

share|improve this answer
    
The same version of Word works well for the other user on my computer. – Adam Matan Mar 15 '13 at 17:46
    
Do you value your Windows account settings particularly? You could try to make another account, move your files over and delete the old one. – Ariane Mar 15 '13 at 18:16
    
It will be the last resort. – Adam Matan Mar 17 '13 at 7:51
    
Or how about you transfer over another user's Office / Word settings only? You'll lose all of your personal settings in Office software, but you'll keep the rest. To do that, you would browse to C:\Users\<You>\AppData and, inside every folder (Local, LocalLow and Roaming), find every Office-related folder and delete them. For example, in Roaming\Microsoft, there is \Office\ and \Word\ (for me at least). Then you would copy over these folders from another user account who doesn't have the same issues. Make sure you get them all. – Ariane Mar 17 '13 at 18:56
    
Oh yeah. Don't forget to make a backup. It's easy to mess up when playing with hidden files. Wouldn't want you to have to reinstall Office, now. – Ariane Mar 31 '13 at 19:59

protected by Community Dec 24 '13 at 10:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.