Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I made a symlink to an folder with mklink on w8x64 between two NTFS partitions on the same disk. All programs think it's a valid folder, but Windows explorer doesn't seem to get this, and displays a shortcut symbol that can't be double clicked. If I click it a prompt appears asking for the correct program to open the file.

Is there some fix for this?

share|improve this question

1 Answer 1

The /D option does the trick...

Long answer: First open the cmd.exe with admistrator rights. Then type:

mklink /D some-Name Path-to-Target-Directory

The /J option which creates a junction might also be useful for SkyDrive and the like, because they don't follow normal symlinks correctly.

share|improve this answer
1  
+1 for working it out. Could you please include the actual command that worked for you? –  terdon Jan 13 '13 at 14:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.