Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am, for better or worse, an administrator on my Windows 7 machine. However, even then, I still need to run certain programs "as Administrator" - for example, Visual Studio 2008 when working with local IIS sites.

I also like to have the extra buttons on my IntelliMouse Optical doing non-standard things, like representing Ctrl and Shift.

However, when in VS running as administrator, these settings aren't picked up, just like my mapped drives aren't picked up - I would understand this if I was logging in as a different user, supplying credentials, etc, but I'm not, I'm just pressing "Yes" at the UAC prompt.

Normally, I'd just right click the item in the start menu and select "Run as administrator", but that's not an option on the context menu for either the Microsoft IntelliPoint Mouse application that appears under "Programs", nor the "Mouse" control panel item.

Running the control panel as administrator also doesn't seem to help.

So has any one got any suggestions on how I can configure my mouse buttons for the elevated version of me that Visual Studio is running as?

share|improve this question
    
You only forgot to say which mouse this is :) –  A Dwarf Oct 9 '09 at 16:27
    
Yeah, sorry ;) IntelliMouse Optical –  Zhaph - Ben Duguid Oct 10 '09 at 9:58
    
If non-elevated applications could mess with elevated applications, that opens up huge security holes. It's more secure, though also much more annoying. –  Phoshi Oct 26 '09 at 12:39
    
Yes, I appreciate the security concerns you raise - I'm effectively asking for either: An elevated app to read the settings from an un-elevated app, or to start a specific control panel item as an Elevated process when it doesn't by default need to. –  Zhaph - Ben Duguid Nov 4 '09 at 22:39
add comment

4 Answers

That would be the IntelliPoint driver software, then. The actual process is ipoint.exe, which on my system, is a startup processes located in HKEY_LOCAL_MACHINE\Microsoft\Windows\CurrentVersion\Run.

It seems that making this process run as an administrator would solve what appears to be the issue, process security isolation. This would explain why a process running as a standard user (ipoint.exe) can't properly communicate with elevated processes (Visual Studio).

Therefore, you should disable the Microsoft IntelliPoint entry in System Configuration, and use one of the methods in this question (such as my answer- use Task Scheduler) to run the process with elevated privileges.

And as a side note, you kind of are running as a different user when you have UAC approved programs running. Same user account, but to facilitate having programs that both run as a with standard user privileges and administrative privileges at the same time, Windows assigns administrative accounts what is referred to as a "split token", which is like a security identifier to start processes. UAC facilitates switching between tokens to start programs in the Windows shell. It's quite a clever solution to the problem: "How do we make a more secure operating system when virtually all developers for the last 10 years have not bothered to care themselves, and not break much?"

share|improve this answer
    
I find it hard to accept this explanation : Why would ipoint.exe behave differently when VS has the focus? It's a system-wide process. –  harrymc Oct 9 '09 at 18:30
    
the process behaves the same, it just cannot access window properties (or hook mouse events or send keyboard events like Ctrl or Shift) of a process that has more privileges than itself. –  mihi Oct 9 '09 at 18:46
    
I can understand this explanation - as that is what appears to be happening - VS is using the default mouse settings, not the ones I've assigned. I'll give these a go on Monday when I'm back in the office - thanks. –  Zhaph - Ben Duguid Oct 10 '09 at 10:01
1  
Sadly this didn't work - running IPoint as admin (through whatever means) just results in the buttons doing their default things in all applications - even though the Mouse Settings dialog assures me that they are configured to do something different. –  Zhaph - Ben Duguid Oct 26 '09 at 12:25
add comment

This likely has to do with an odd implementation detail in the way Microsoft handled the Run as Administrator. Rather than granting you privileges, it runs it as if you logged in as Administrator and consequently all of "your" settings go out the window. If there is an easy way to save your settings, try loading them into the mouse software as administrator.

share|improve this answer
    
Yes, but that's what I'm trying to do - run the mouse software as admin - I would just log on as that user, but it's not a separate user, just me with elevated privileges. –  Zhaph - Ben Duguid Oct 10 '09 at 10:00
add comment

I have a very similar problem. The workaround is to turn off UAC completely. The mouse buttons are then seen as keystrokes.

share|improve this answer
add comment

I see you still haven't found a solution, so I'll share mine:
I was in a similar situation with my Logitech G5, so to fix it I used AutoHotKey instead of the default control panel, which CAN run elevated and remap keys properly.

share|improve this answer
    
Phoshi, could you elaborate on how you used AHK to solve this issue? –  mindless.panda Apr 15 '10 at 17:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.