Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using an Asus P8Z68-M Pro motherboard and a PS/2 Keyboard. My keyboard does not work in boot menus like when I'm selecting an OS and when selecting which kind of Windows safe mode to use. The keyboard works fine at all other times without any problem. The keyboard even works in the ASUS UEFI BIOS Utility.

Can anybody please guide me to what I can do to solve this issue?

Oh, and one more thing: I found this neat little trick to bypass this bug, i.e. to keep hitting any of the arrow keys when the computer loads. Then the keyboard works fine for that particular session. But this is not very practical on a day-to-day basis.

share|improve this question
    
keyboard not working doesn't translate to OS being corrupt, specially at boot menu since there's no OS loaded, yet –  WikiWitz Jan 13 '13 at 12:23
    
I know. I didn't say it had something to do with the OS. –  Hele Jan 13 '13 at 13:14
    
If it works in BIOS, fails in low level windows menus, and works again in the actual OS environment, this sounds like a Windows driver problem. Is there something special about the keyboard apart from being PS2? Shot in the dark here, but does it work if you boot with no USB devices connected to the computer? –  terdon Jan 13 '13 at 14:55
    
Its a modern Logitech Keyboard. I'll try the no-USB thing as soon as possible and let you know. –  Hele Jan 13 '13 at 15:57
    
When I connect only the keyboard and the mouse, it works like a charm. So what exactly is the problem? –  Hele Jan 14 '13 at 10:50

1 Answer 1

I had this same problem today, when I was trying to boot from a USB stick and couldn't move around in Boot Menu. It used to work fine with my old keyboard which was connected to a PS/2 port, but for a year now I've been using a new keyboard (Logitech K120) over USB, which won't work by default.

I'll guess you are running on some older BIOS version, which does not have USB keyboard control enabled by default - you need to enable it manually. Newer versions mostly have it enabled by default.

  1. Reboot pc.
  2. Enter BIOS.
  3. This step may vary in different BIOS versions. In my case the PC had a Gigabyte motherboard: Select Interface of Integrated Peripherals from the main BIOS menu and locate the USB Keyboard Support option and set it to Enabled it. In case you use a different BIOS version try to search around - look also for "Legacy USB support" or "Legacy USB keyboard" and similar named options.

BIOS option sample

  1. Save and exist BIOS and try the Boot Menu again.

If the above does not work, you can try plugging the keyboard to other USB ports and see if it get's detected, although it's rarely the case that one of the USB ports is treated as primary (shouldn't be).

share|improve this answer
    
Thank you for the reply! I dont have access to the system I used at the time but it was a PS/2 keyboard, not a USB one. –  Hele Apr 21 at 1:16
1  
@Hele yeah - it's an old question and maybe does not solve your problem specifically, but I'm still posting it here since I had to spend quite some time fiddling around with various settings and ideas before I made it work. –  easwee Apr 21 at 10:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.