Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have problem configuring my network. Between switches I created vlans: 5,6,9 and 10. Vlan 9 is the native vlan. PC1 is in vlan 5 and PC0 is in vlan 6. I configured R1 that is possible to communicate through different vlans (ping from PC0 to PC1 works fine). Now I want to ping R3 se0/2 interface from PC1 but I have no response. Here are my configuration files:

SWITCH S1:

Current configuration : 942 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S1
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet1/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet2/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet3/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet4/1
!
interface FastEthernet5/1
!
interface FastEthernet6/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet7/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet8/1
!
interface FastEthernet9/1
 switchport trunk native vlan 99
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

SWITCH S2:

Current configuration : 830 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S2
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet1/1
!
interface FastEthernet2/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet3/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet4/1
!
interface FastEthernet5/1
!
interface FastEthernet6/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet7/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet8/1
 switchport access vlan 6
 switchport mode access
!
interface FastEthernet9/1
!
interface Vlan1
 no ip address
 shutdown
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

SWITCH S3:

Current configuration : 830 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S3
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet1/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet2/1
!
interface FastEthernet3/1
!
interface FastEthernet4/1
!
interface FastEthernet5/1
!
interface FastEthernet6/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet7/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet8/1
 switchport access vlan 5
 switchport mode access
!
interface FastEthernet9/1
!
interface Vlan1
 no ip address
 shutdown
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

ROUTER R1 :

Current configuration : 1039 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.5
 encapsulation dot1Q 5
 ip address 192.168.5.1 255.255.255.0
!
interface FastEthernet0/0.6
 encapsulation dot1Q 6
 ip address 192.168.6.1 255.255.255.0
!
interface FastEthernet0/0.9
 encapsulation dot1Q 9
 ip address 192.168.9.1 255.255.255.0
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.2 
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

ROUTER R2 :

Current configuration : 649 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.10.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 172.16.1.2 255.255.255.0
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

ROUTER R3 :

Current configuration : 690 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 172.16.1.1 255.255.255.0
 clock rate 64000
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.1.2 
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

ROUTIG TABLES, R1:

R1#sh ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.2 to network 0.0.0.0

C    192.168.5.0/24 is directly connected, FastEthernet0/0.5
C    192.168.6.0/24 is directly connected, FastEthernet0/0.6
C    192.168.9.0/24 is directly connected, FastEthernet0/0.9
C    192.168.10.0/24 is directly connected, FastEthernet0/0.10
S*   0.0.0.0/0 [1/0] via 192.168.10.2

ROUTIG TABLES, R2:

R2#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Serial2/0
C    192.168.10.0/24 is directly connected, FastEthernet0/0

ROUTIG TABLES, R3:

R3#sh ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.16.1.2 to network 0.0.0.0

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Serial2/0
S*   0.0.0.0/0 [1/0] via 172.16.1.2

My topology: http://s6.ifotos.pl/img/screen6pn_xwqenpw.png

How can I change my network configuration to be able to ping from PC0/PC1 to 172.16.1.2 or 172.16.1.1 ?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I can't add comments, but as far as I can see, you don't have route from PC0/PC1 to reach R3.

You can reach from PC0 to PC1 because they are somewhat connected into the same network, even if onto different VLANs. You will need to construct a routing table, throughout your network so your PCs may reach R2/R3.

The basic route you need to add is pointing 172.16.1.0/24 to the internal IP Address of R2.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.