Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have many zip-files where there are encoding errors for the German umlauts (äüöÄÜÖß). They show up in both the filename.zip as well as in the included directories and files like this:

  • Fünf = Fu╠ênf
  • Räuber = Ra╠êuber
  • Überfall = U╠êberfall

and so on. Usually I use Linux, but because of this issues I also tried a Windows7 VM but it results in the same encoding mess up. On Linux I played around with convmv and detox, but with no success.

When I use

  • convmv -f iso-8859-1 -t utf8 --replace --notest -r *

I get "Skipping, already UTF-8".

Any thoughts about this?

share|improve this question
    
What antique system are you using ? All current Linux distributions uses UTF-8 now. –  BatchyX Jan 13 '13 at 15:51
    
Could this be a filesystem problem? Perhaps it is not mounted in UTF? –  terdon Jan 13 '13 at 15:59
    
I use Linux Mint 13 (based on Ubuntu 12.04 LTS with Kernel 3.2.0-23), so this is far from antique. And as I already wrote I also tried that files on a Windows 7 VM. But of course I don't know what the one who created the zip files used. –  cider Jan 13 '13 at 15:59
    
This encoding seems some kind of DOS encoding. Usually if I see issues with UTF8 encoding the German umlauts look like ä = ä or Ü = Ãœ –  cider Jan 13 '13 at 16:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.