Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Internet connection works just fine when it’s manually connected via a cable to my modem, but when I tried enabling my Wi-Fi connection, it doesn’t seem to work.

I have 4 LAN ports in my modem and I connected the first one with my laptop and the second with my router. Now my laptop picks up my Internet connection, and my wireless signal but the wireless won’t connect.

I tried unplugging the cable from my modem to my laptop and tried enabling my Wi-Fi, but that doesn’t work either.

share|improve this question
1  
You'll need to provide more details about how your wifi router is set up. – jjlin Jan 13 '13 at 20:01
    
It's a belkin router and I dont think there's a problem with my router because my other devices seem to pick up the wireless signal, just not the actual connection. It's connected to a power outlet and my modem. I tried switching the cable from my laptop to modem directly to my router from the laptop, but that doesnt work too. – subhu Jan 13 '13 at 20:31

Since your "modem" has 4 LAN ports, it's also a router. You don't want two routers in the same LAN if you can avoid it, and you can. So just use the wireless router as an access point or bridge.

  1. Disable the DHCP server in your router.

  2. Connect one of your router's LAN ports to the modem's LAN port.

  3. Do not connect the router's Internet/WAN port to anything.

  4. (Optional) Configure the router's LAN IP to be an IP address inside the subnet your modem serves but outside its DHCP range.

  5. (Optional) Disable the router's WAN port or, if supported, configure the router to bridge that port to your LAN.

You can now use the router's WiFi and available LAN ports to connect devices to your network.

share|improve this answer

protected by bwDraco Nov 18 '15 at 21:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.