Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Google Chrome. I re-installed it today as it was crashing when I start it. I guess may be that this was due to any of my Extensions or Google Update. I disabled my extensions but it was still crashing. Now I installed an old version of chrome from http://www.oldapps.com/google_chrome.php. However, Chrome automaticallyuppdates itself (although Windows asks me before installing and I don't grant it permissions, its still annoying to get Google update asking me permission after a couple of minutes.

I saw the question at Disable auto-update of Google Chrome however, it doesn't seem to hlp me. i disabled the service and I stopped it as well, but the problem still persists. I also tried to look into the registry according to the following link: http://www.sitepoint.com/how-to-disable-google-chrome-updates/ but the "Policies" section of my registry doesn't contain any folder called "Google". I use Windows 7 - 64 bit Home Premium Service pack 1.

Could anybody help? Thanks a ton!

share|improve this question
1  
Did you try simply creating the registry key? It doesn’t exist by default because Google doesn’t want to make it easy to disable auto-updates. Also, be aware that even if you disable the update plugin (in chrome://plugins), it will spontaneously re-enable now and then (whenever Google wants). Likewise, deleting the Google Update Windows Scheduler tasks is no good because Chrome keeps recreating them. Instead, just disable them; so far that works… for now. –  Synetech Dec 13 '13 at 3:33
    
Thnx!. That's useful. :) –  TheRookierLearner Dec 13 '13 at 6:02
add comment

3 Answers 3

up vote 9 down vote accepted
  1. Download a windows group policy template "Google Update Administrative Template" from Google Site.

  2. Open the editor by typing "gpedit.msc" into the search button on the start menu and click the resulting link

  3. Navigate to User Configuration - Administrative Templates Step 3

  4. Right click on Administrative Templates, select add/remove templates from menu bar.

  5. In the popup box click add button and navigate to where you downloaded the GoogleUpdate.adm file and then click close button Step 5 Step 5-2

  6. You should find a new entry under Local Computer Policy - Computer Configuration - Administrative Templates - Classic Administrative Templates called Google Step 6

  7. Navigate to Administrative Templates - Google - Google Update - Applications - Google Chrome.

  8. Right click on Update Policy Override and select edit.

  9. Click enabled button and in the scrollbar list under Policy choose Updates disabled and click OK

  10. To be sure that update not occur, Go to Start > Run > msconfig > Startup > Disable GoogleUpdater.exe

You have now stopped Google Updater from checking for updates for Google Chrome

share|improve this answer
    
Everything goes fine till step 5. In step 6 I don't get any Classic Administrative Templates called Google –  TheRookierLearner Jan 14 '13 at 4:49
    
I tried it a minute ago and it worked like a charm. In step 5, in the popup dialog, are you able to see an entry like "GoogleUpdate 250KB"? –  Hele Jan 14 '13 at 5:22
    
No. Initially, I got a dialog saying "The file has a name that is too long or in invalid" So, I renamed it to "GUpdate" then nothing happened. But I didn't see any entry too. –  TheRookierLearner Jan 14 '13 at 5:26
    
Try re-downloading the file. Do you have teamviewer installed? –  Hele Jan 14 '13 at 5:38
    
Yeah, i do have it. –  TheRookierLearner Jan 14 '13 at 6:20
show 3 more comments

from http://productforums.google.com/forum/#!topic/chrome/GrNPXViSjpI

  1. Control Panel -> Administrative Tools -> Schedules Tasks (or search for Task Scheduler in Control Panel) . Look for Active Tasks, delete all Google Auto Updates Tasks
  2. From Chrome browser, open chrome://plugins/ , disable Google Update.
  3. From Start menu, run msconfig.exe -> Start up tab, disable Google Update ( though it seems automatically come up again)
share|improve this answer
add comment

One method to disable silent updates in Chrome is to manually add the policies to the Windows Registry. The Windows Registry key responsible for determining how Google Update updates Chrome can be found in the following Registry key and value:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Update "Update{8A69D345-D564-463C-AFF1-A69D9E530F96}"

This value can have 4 different DWORD settings assigned to it that describe how Chrome will be updated. These different DWORD values are:

0 - This setting corresponds to the Updates disabled policy setting. This means updates are completely disabled for Chrome.

1 - This setting corresponds to the Always allow updates policy setting. This means that updates are always installed regardless of whether they were found via periodic silent updates or a manual update check.

2 - This setting corresponds to the Manual updates only policy setting. This means updates are only applied when a user performs a manual check.

3 - This setting corresponds to the Automatic silent updates only policy setting. This means updates are only installed when they are found via the periodic silent update check.

To change the Google Update setting for Chrome simply create the above key and value and assign one of the above value.

If you don't wan to play with registry then download the following registry files and run them. The first one will enable Manual updates and the second one will restore Chrome back to its normal defaults of updates being installed via silent updates or manual updates.

Registry file to set Chrome to Manual Updates only
Registry file to reset Chrome back to its default update policy (Manual+Silent Updates)

Simply download one of the above Registry files and save them to your desktop. Then double-click on the registry file and allow the changes to be merged into the Registry. The changes to Google Update for Chrome will now be set.

For more you can read this source.

share|improve this answer
1  
I don't have a folder called "Google" in the "polocies" section of my registry. –  TheRookierLearner Jan 14 '13 at 6:32
1  
@TheRookierLearner, that’s normal (Google has no desire to make it obvious how to disable auto-updates); just create it. –  Synetech Dec 13 '13 at 3:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.