Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have virtual box 4.2.4 installed in Windows XP SP 3 and Oracle Linux is installed in Virtual box.

When I start linux on Virtual box, I have noticed that both my host and guest machines becomes unresponsive, means it will take a long time to launch a program or open a file. If I shutdown guest OS, then host OS will become normal.

What could be the reason for this?

I had quite a few improper shutdowns on my guest OS, due to this file system got damaged?

Any help is highly appreciated.

Thanks

Update 1

Memory Allocation

enter image description hereenter image description here

Update 2

share|improve this question
    
Windows XP is the 32bit version right? And is the installed Linux 32bit as well? I think it has to be. –  Matt H Jan 14 '13 at 23:49
    
Are you using the very latest version of virtual box? –  Matt H Jan 14 '13 at 23:50

4 Answers 4

If the guest is on the same drive as the host OS, move the guest to an external or a different physical drive and see if the performance improves. If both OSs are trying to use the same drive, you will have issues.

Also make sure you have not allocated too much RAM or Processors to the guest.

In most cases I have seen, it is hard drive and using an external USB 3, eSATA or even USB2 drive will make a big difference.

share|improve this answer
    
I have added screen shots of my memory allocation as update 1 by editing my question, kindly suggest how much memory should I reduce? –  Polppan Jan 14 '13 at 2:10

Several reasons.

  1. How much memory do you have on your host?
  2. How much memory are you giving your guest?
  3. How many CPU cores do you have on your host?
  4. How many are you allocating to your guest?

I think you may be giving your guest too much. The host needs a certain amount of resources to run I/O for the guest.

share|improve this answer
    
I have added screen shots of my memory allocation as update 1 by editing my question, kindly suggest how much memory should I reduce? –  Polppan Jan 14 '13 at 2:11

The most probable reason for this is lack of operational memory. When this happens the Host OS will try to allocate the required memory for the Guest. At that time, due to insufficient memory resources, the Host will begin swapping/paging. Now you are hitting the hard drive, where this process occurs and everything is s-l-o-w. You have two options:

  1. reduce the required memory for the Guest OS;
  2. upgrade the Host OS RAM (buy more RAM).

Bonne chance!

share|improve this answer
    
How to find out how much memory I have allocated to guest OS? –  Polppan Jan 14 '13 at 2:02
    
I have added screen shots of my memory allocation as update 1 by editing my question, kindly suggest how much memory should I reduce? –  Polppan Jan 14 '13 at 2:11
    
@Polppan - as per your first screenshot you have allocated 1GB for your VM. Now, how much memory you have on the Host OS? –  grs Jan 14 '13 at 3:58
    
I have 3GB on my host OS –  Polppan Jan 14 '13 at 4:03
    
OK, so close all your applications, start the VM and post the result here. Does it make a difference? If not, reduce your VM memory to 512 MB and try again. Post the result here. –  grs Jan 14 '13 at 4:06

Try allowing the guest OS to use both CPUs/cores in your system by sliding the "Processor(s):" slider to 2 (Second screenshot). This should balance the guest OS between both cores instead of dumping it all on the first one, which might be the cause of the slowness.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.