Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't ping from Windows 7 box in my network, but:

  • Other machines CAN ping to it
  • It does navigate normally on the Internet

When I ping I get the following error message:

PING: transmit failed. General failure.

share|improve this question
Do you get a timeout or an error? – Chris Thompson Oct 9 '09 at 18:31
What O/S are the other machines? Have you tried turning off all firewalls? – harrymc Oct 9 '09 at 19:16
Are you able to ping yourself? Either localhost or – Chris Thompson Oct 9 '09 at 19:29
The usual overly-helpful windows-style error messages...reminds me of the "General Protection Fault" days... – marcusw Jan 28 '10 at 2:30

I saw the same problem on a Vista system. It turned out that the AV software (Trend Micro) had a built-in firewall that was causing the problem. Disabling the AV firewall fixed it.

share|improve this answer

In general, this error occurs if there is no routable interface on the system for the address you provide. Since the OS can't determine what interface to use, ping fails and provides this error. Common scenarios can include:

  • No default route set for the host (ping may still succeed to hosts within the subnet, or those with static routes)
  • Interface holding the default route is down or disabled
share|improve this answer

try to disable all the others adapters on the system, leave just the one you are using for internet connection, and try again.

share|improve this answer

If you're pinging a *nix box, and you've set a MAC address for your ethernet device (or didn't set one at all), set the MAC address of the device to any 12 digit number starting with 0.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .