Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running into an issue on Snow Leopard. I am just using the standard Apache2 that came with it but it doesn't seem to want to use my .htaccess file. Here is the appropriate part of my httpd.conf file:

<Directory />
  Options FollowSymLinks
  AllowOverride All AuthConfig
  Order deny,allow
  Deny from all
</Directory>

And here is my .htaccess file:

Options +FollowSymlinks
RewriteEngine On
RewriteBase /

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L,QSA]

I'm sure I'm doing something stupid, but at this point, I just cant see it!

All it's doing is allowing me to not have the index.php file, this worked on Leopard and isn't working in Snow Leopard. What am I missing?

share|improve this question
    
Questions about server configuration (such as Apache) are probably better suited for serverfault.com –  David Pearce Oct 9 '09 at 20:53
    
oops! didn't even realize that existed! Should I just reask there or can you guys move it? –  user13771 Oct 9 '09 at 21:26
    
Don't re-ask; it will be moved if people think it's required. –  Arjan Oct 9 '09 at 21:59
    
Did you upgrade to SL, or is this another machine/new installation? –  Arjan Oct 9 '09 at 22:01
    
And does any of the hints at superuser.com/questions/53303/… work for you? –  Arjan Oct 9 '09 at 22:03
show 1 more comment

3 Answers 3

Do you have the apache mod_rewrite extension installed and enabled? It might have been removed/changed when you updated.

share|improve this answer
1  
yep, mod_rewrite is loaded –  user13771 Oct 9 '09 at 21:25
add comment

hey, I had the same problem on my new computer and I found out it is because Snow Leopard automatically created a new config under /etc/apache2/users/, so go ahead and change the content like:

<Directory "/Users/<username>/Sites/">
  Options FollowSymLinks Indexes MultiViews
  AllowOverride All
  Order allow,deny
  Allow from all
</Directory>

Hope this works for you.

share|improve this answer
add comment

Same prob here. My fix included both editing the "yourusername.conf" file as well as relaxing some of the similar restrictions about half way down the apache2/httpd.conf file.

Hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.