Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In previous versions of Word, I could just put my cursor into a paragraph or select the whole paragraph, and change the tab settings - it wouldn't change the settings of any other paragraph. In Word 2007, changing the tabs setting updates the whole document. How can I restrict my changes to a single paragraph?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Word 2007 didn't introduce any new behavior regarding this. When you select or place the cursor inside a paragraph, any paragraph-wide formatting will be applied to that paragraph only, retaining the integrity of the rest of the document.

Now, what you are almost certainly experiencing is a problem with the automated update feature for styles. This is an old feature (as old as styles in Word) that, once enabled, means any formatting changes to a paragraph using that style, will update the style definitions, which results in the remaining paragraphs using this style to be updated.

Let's get over with the simplest of cases:
This isn't happening to you on paragraphs using the Normal Style.
On this case:

  • just right-click the style from the Ribbon Menu you are using on the afflicted paragraph and select modify.
  • Untick the Automatically update check box

Hopefully this is enough for you. If not, read on...


Some users have this problem with the Normal style. Which is very odd. I'm actually unsure as to why that would happen. If you right-click the normal style and select modify, you will see you don't have that checkbox. This style cannot be set to update automatically. But with some people it does(!).

To fix this issue:

  • Open the Document you are working on.
  • Press ALT+F11. This will open up the VB Editor.
  • Go to the View menu of the editor and select Immediate Window. This is where we are going to type our command to disable automatic updating of styles.
  • Type: ActiveDocument.Styles(wdStyleNormal).AutomaticallyUpdate = False
  • Hit ENTER
  • Still on the VB Editor, click the File menu and choose to save your document.

The new document will behave as you want it to.

EDIT:
Forgot one last bit of information...

It's possible that when you open a new Word document when firing word.exe, the problem will resurface either on the same regular style, or the Normal style (whichever was your case). To fix this, you'll need to update your Empty Document Template. To that effect:

  • Fire up Word from the executable or icon in your Start Menu (do not fire it up from an existing document)
  • Make the changes suggested above again, whatever your problem was (either a regular style, or the Normal style).
  • After that, Right-Click again the style on the ribbon bar and select Modify
  • Make sure Add to Quick Style list is checked and check New Documents based on this template
  • Click OK
  • Exit Word

New documents will now behave.

share|improve this answer
    
This sounds entirely plausible. I got the document from someone else, so it could easily be set up differently than everything I've done on my own. And yes, it was the Normal style. Unfortunately it will probably be Monday before I can try this out. Thanks! –  Mark Ransom Oct 10 '09 at 3:47
    
Thank you, this worked perfectly even though AutomaticallyUpdate was already False. Unfortunately I was forced to use a table instead of tabs because of other formatting problems. –  Mark Ransom Oct 12 '09 at 15:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.