Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to set up a machine here with UltraVNC on Windows Vista with UAC off. The problem is, in this configuration, I can't send Ctrl + Alt + Del (CAD) to the Windows Vista machine, and so I'm stuck at the login screen, which is waiting for the CAD sequence. I'm joined to a domain, so I don't think I can disable the CAD requirement. I can't re-enable UAC either. I also tried using the on-screen keyboard, but it didn't seem to work. Is there a workaround or a solution?

share|improve this question
    
right click on the menu bar, not the item in your task bar –  user33400 Apr 6 '10 at 16:10
    
Setting the UAC to the 2nd lowest level worked for me, i use Windows 7 Ent with UltraVNC. It takes about 5-6 sec for the command to go through, but it works. Thanks who ever gave that answer, saved me a bunch of time =D –  user49632 Sep 17 '10 at 12:13

6 Answers 6

Doesn't VNC have a feature to send CAD? With RealVNC you can click the VNC-window's icon (at the top left corner) and click "Send Ctrl-Alt-Del". Maybe there's something similar? Otherwise you can of course use RealVNC's client.

share|improve this answer
    
That's the problem. Something on the server end has to actually send the CAD once it has been instructed to. On Vista that's broken because of the changes to session isolation. –  jasonh Oct 11 '09 at 4:15
up vote 1 down vote accepted

After much searching, I gave up and set group policy on the machines to not require Ctrl+Alt+Del.

share|improve this answer
1  
This does not answer the question you asked! –  David Heffernan Apr 11 '13 at 22:19

The latest release of UltraVNC and VNCScan have resolved this issue. There's a pretty thorough post of it at http://vncscan.com/blog/2010/09/ultravnc-and-windows-7-ctrlaltdel/

share|improve this answer

Set your UAC to the second-lowest level. This will allow you to send Ctrl+Alt+Del to the remote computers through VNC and other remote software.

share|improve this answer

I wrote a library called SasLibEx that can simulate the CAD keypress sequence, even when UAC is disabled. Some of my customers use it with UltraVNC.

share|improve this answer

There is a registry setting that can be changed that will allow Ctrl + Alt + Del to work. I'm not sure what the setting exactly is, as the incorrect setting was detected by VNC and provided me with the option to make the change itself. Here's how I went about it:

  1. Log in to the remote computer (so that when you connect via the VNC Viewer you won't be prompted with the "Ctrl + Alt + Del" screen).
  2. On another computer, use the VNC Viewer to connect to the remote computer.
  3. Press the Send Ctrl+Alt+Del to Host button on the toolbar. At this point, the VNC Server shows a message, "UAC is diabled, fix registry". Click OK.
  4. After this registry fix, Ctrl + Alt + Del commands work as expected.

This post TRUE solution for Ctrl-Alt-Del in Win7? + other issues gets credit for pointing me in the right direction.

share|improve this answer
    
If you don't know what the registry setting is then your answer is useless. –  Ramhound Mar 6 '12 at 18:07
    
@Ramhound There's no need to modify the registry manually. I was only indicating that a registry value does get changed. –  Matt Hanson Mar 7 '12 at 1:53

protected by studiohack Apr 27 '11 at 1:13

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.