Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to enable Teredo on a Win7 SP1 x64 system, in order to provide Remote Assistance for a system outside the local network. The local system is joined to a 2008-level domain which I have full control over.

I attempt the following command:

netsh interface ipv6 set teredo type=enterpriseclient

The response is "Ok" and yet if I then use:

netsh interface ipv6 show teredo

even after rebooting, it will show:

Teredo Parameters
Type                    : disabled
Server Name             :
Client Refresh Interval : 60 seconds
Client Port             : 34567
State                   : offline
Error                   : none

I cannot ping IPv6 addresses although my DNS server retrieves AAAA records fine.

I have enabled the IPv6 protocol on the network interface and I have also set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters\DisabledComponents to 0.

I've also tried client instead of enterpriseclient (not sure what the actual difference is), to no avail.

Furthermore, the Teredo Tunneling Pseudo-Interface does not appear anywhere in Device Manager even when I enable "Show hidden devices."

share|improve this question
up vote 1 down vote accepted

I managed to solve this particular issue, although my IPv6 is still not working, for other reasons.

First of all, I uninstalled ZoneAlarm Free Firewall. I'm not sure if it was causing this problem but I've read about it causing problems with IPv6.

The Microsoft Teredo Tunneling Adapter was in fact missing. I have no idea how it got missing, other than perhaps ZoneAlarm removed it. This I solved as follows:

  1. Run Device Manager as admin.
  2. Right-click on the computer's name at the top of the tree view and pick "Add legacy hardware."
  3. Opt to manually select the device.
  4. Choose Network adapters, then Microsoft, then "Microsoft Teredo Tunneling Adapter."
  5. Complete the wizard to install the adapter.

At this point you shouldn't see Microsoft Teredo Tunneling Adapter in Device Manager unless you check View->"Show hidden devices." However, for me, once I got the driver installed, it did show and with a yellow exclamation icon, revealing the error "this device cannot start (code 10)."

It turns out this was due to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters\DisabledComponents having been set (in the registry) to a non-zero value. I had previously set it to zero and double-checked this, so somewhere along the line either removing ZoneAlarm or installing the Teredo Tunneling Adapter caused this setting to get overwritten automatically.

Once I set DisabledComponents back to 0 and rebooted, the Teredo adapter enabled uneventfully into enterpriseclient mode using the commands stated in the question.

There are some detailed notes on Teredo which may prove useful once the Teredo adapter is enabled, here:

share|improve this answer

just open your registry and go to below address:


look the right tab, then doubleclick DisabledComponent, choose decimal then set it to 0. restart your pc, and done.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .