Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My system

I have a dual-boot setup with windows 8 and linux debian testing on a lenovo X1-carbon laptop with a 256GB SSD drive. I've made a shared partition in the NTFS format, and use this partition a lot both in windows and linux. Furthermore, on the shared partition I have a dropbox folder, such that I can use dropbox actively both in windows and linux, without filling up my drive with redundant data from two separate dropbox instances.

For the time being I mostly use linux, but I'm probably going to use windows a lot more in a near future because I want to use Visual Studio a lot.
(I have tried using a virtual machine for linux inside windows, -and I did not like it because of the poor performance)

The problem

Weird drive errors occurs, and when I try to fix them with the windows repair-drive-at-next-boot tool, the problem goes away for a long duration like 7-14 days, but then suddenly the problem is there again...

In windows, the error is revealed with a system notification (you know, the flag in the lower right corner), and it suggests to repair the drive at next boot up. I've tried doing that each time the error occurs, and it sure fixes the problem, but the error seems to return after 7-14 days.

In linux the error is revealed primarily by weird behavior by dropbox, which seems to sync forever without ever finishing, and when the error occurred today, I logged into linux and got following dropbox prompt:

Couldn't start Dropbox

This is usually because of a permissions error. Errors can also be caused by your home folder being stored on a network share. get more help at ......( links)


Furthermore, I've seen errors like: ls: cannot access network.txt: Input/output error where network.txt is just an arbitrary text file created by me in my dropbox folder long time ago... When I try to open the text file with Vim it appears empty, even though there should be some text in it, and in the bottom of the window it says "[Permission Denied]".

Furthermore, I have at one time experienced that either the windows or linux Dropbox application, -startet spamming corrupted conflicting copy files into dropbox. (when I discovered it, it had already created hundreds of corrupted files)

Regarding editing of files in the dropbox folder, I've noticed that when I edit some files in libre office in linux and save the files to the dropbox folder, -the edited changes will not be there in windows until dropbox is done syncing.
It's like the file changes were never saved on the actual hard drive, but only send to the dropbox server. (I've only noticed this so far with .odt files in libre office)

Dual-boot experience in the past

I had a very similar dual-boot setup on my previous laptop, which ran windows 7 and debian testing, and also had a SSD drive with a shared partition -with a shared dropbox folder on it. Everything has always worked flawless on that laptop, without any weird drive errors.

My weak guesses at what could be wrong with the current system setup:

  • Maybe some sectors in the SSD drive hardware are faulty, and then the error will occur when files accidentally ends up in these sectors...
  • Maybe windows (or linux) does something to the files (or their arrangement), which causes confusion between the windows OS and the linux OS... (like for example changing the permissions)
  • Maybe the linux Dropbox application and the windows Dropbox application are doing something to the files in very different ways, which for some reason causes the confusion about the drive states in the operating systems...


Even though I do use linux on a daily basis, I have no idea about how to debug such a problem and where to even start. I do have some very basic knowledge about computer architecture, assembly and C, but I only play around with higher level programming languages (C#, java, python)...

It would be nice if someone can give some clues at how too debug such a problem, either in windows or linux or both.
Does there for example exist some reliable tools or easy methods to check if the drive actually is faulty..?

share|improve this question

Here is my suggestion based on lots of experience - don't share the data partition and in WIN 8 and don't let WIN 8 map any drives/partitions accessed by the other partition. I had this exact same problem on a WIN7/WIN8 setup. Even repartitioned and reformatted the data drive. And the issue was very repeatable, every time I used WIN 8 data on the shared partition would get corrupted. VS 2012 will run on WIN 7, and that setup is much more stable.

share|improve this answer
How is this relevant to sharing an NTFS drive between Linux and Windows? I have been sharing (without dropbox) drives between various versions of windows and Linux for years with absolutely no problems. – terdon Jan 14 '13 at 13:36
I had a shared data partition WIN8 and WIN7 dual boot setup, WIN8 first starts corrupting file permissions then eventually destroys the file when you allow it to "fix" errors. Same shared drive works fine now with WIN7 and UBUNTU. – jtreser Jan 14 '13 at 14:10
BTW this link suggests another way to handle this - using FAT/FAT32 for the shared… – jtreser Jan 14 '13 at 14:13
Thank you for your inputs jtreser.. I'm a bit sad to hear that it could be a windows 8 problem :(.. But it sounds like it could just as well be a linux problem, if the "NTFS-3G utilities doesn't mark the filesystem as clean" (like they discusses in the post you linked to)... If the ntfs utility in linux doesn't mark the partition as clean, then maybe the problem can be solved by making a script which closes dropbox, unmounts the partition, and then run this script before shutting down or restarting.? (Of course FAT also sounds like an option, I just don't like the file size limit) – Mitzh Jan 14 '13 at 17:10
Yeah Windows 8 is very aggressive in (mis)diagnosing drive errors and trying to correct them. I run windows 8 and 7 dual boot and I observe this... Want some way of telling Windows 8 to keep to its own drives and leave the rest alone. – Milind R Oct 9 '14 at 16:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .