Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Due to some other conflicts, I disabled/stopped NetworkManager in Fedora 15.

Now, for network configuration I used system-config-network-gui to config & enable Ethernet interface.

Problem is, when the system starts, the Ethernet does not become enabled. Although in configuration through system-config-network I specifically checked:

"Activate device when computer starts"

"Allow all users to enable and disable the device"

and cleared "Controlled by NetworkManager"

I double checked the config file "/etc/sysconfig/networking/devices/ifcfg-eth0" to see if the configurations are saved correctly and onboot is enabled. And they look OK.

So, Why does it still not become enabled automatically on boot?

share|improve this question
in file, /etc/sysconfig/network, I have NETWORKING=yes – Saeed Jan 14 '13 at 13:52
you need to chmod +x /etc/sysconfig/network-scripts/ifcfg-eth0 so it can be enabled at boot. I could be wrong with the file name thou .. never used Fedora 15 – WeloSefer Jan 14 '13 at 23:01
Thanks WeloSefer, but I'm looking for a proper way to do so, not a hack. the current permissions are -rw-r--r--. /etc/sysconfig/network-scripts/ifcfg-eth0 – Saeed Jan 15 '13 at 8:36
It's not a hack. For my system, whenever I need some script to be included on boot, I enable execute bit on the file and add a line to my rc.local file which looks something like this if [ -x /etc/rc.d/rc.vnstat ]; then /etc/rc.d/rc.vnstat start fi. That line ensures the script is included at boot. By looking at the file permission you included, execute is not set for any user so the first thing you should try is chmod +x and reboot the system. – WeloSefer Jan 15 '13 at 17:27
Thans WeloSefer, I got a better answer in Unix&Linux stackexchange it was a linux bug, in bugzilla – Saeed Jan 16 '13 at 11:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.