Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to use Ctrl+S in Eclipse to save the current document, it doesn't save the document. In fact, it skips and highlights the next "S" in the document, and continuing to press "s" will skip from "s" to "s" in the document. I have reset my key bindings in eclipse, and even manually set both of the "Save" commands (one in File, the other in Application Category). I've looked for key bindings that have only Ctrl, but nothing pops out.

I don't have any scripts (like AutoHotkey) running. I'm running Eclipse 4.2.1. This randomly started happening, so I'm pretty sure its a bug on my side (especially with it being such a basic command on a solid IDE).

My guess is that its a plugin, or some other program interfering, but I don't know.

share|improve this question

migrated from stackoverflow.com Jan 15 '13 at 2:05

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer 1

You may have switched to "Emacs" mode. In Emacs, Ctrl-S is the inline-search key.

Go to Window -> Preferences -> General -> Keys

and look at the "Scheme:" control.

It probably should say "Default" unless you know what you are doing. If that's not it, type "Ctrl+S" in the large field under the Scheme control and see what shows up. If you don't see the "Save" command, you'll need to configure it.

share|improve this answer
    
I am on default, and Ctrl-S is there. Something is blocking all of the basic Ctrl commands (Like Ctrl-S, Ctrl-F, Ctrl-X and so forth). I've ended up having to redefine all of them and memorize what they are. –  MrTi Feb 22 '13 at 23:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.