Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an internet connection, it seems to work fine. I am not in offline mode (nor can I switch to that). For some reason when I try to launch steam it just hangs on "Connecting to Steam account: xxxxxx". When I open task manager, I can that it is doing I/O writes, not sure to what though. So it isn't dead, just stalling really. It eventually will just timeout and say that it cannot connect to steam. Rebooting did not fix the problem, and this is not the first time it has happened. Switching user accounts on the same computer does not help either. Neither has trying another laptop which has steam (same account) installed. It is doing this on 2 separate networks also, my Hotel's WIFI (not the fastest but it appears to be working fine) and my 3g DTAC (cell) Network card. I am currently in Thailand if that matters, perhaps it is trying a server here that is down?

share|improve this question
2  
Have you tried reinstalling Steam ? You can do this without redownloading all your games, and it will retain the settings if you so desire. –  pleinolijf Jan 15 '13 at 13:40
    
What about files (like save progress in touchlight 2 to be most specific) that haven't been synced to the steam cloud yet? –  Zombies Jan 15 '13 at 13:41
    
Shouldn't pose a problem. Steam will just reinstall its program files, and your user settings, save games, game files will not be touched. Try reinstalling without uninstalling first. If that doesn't fix it, it's likely to be a misconfiguration of some kind... –  pleinolijf Jan 15 '13 at 13:44
1  
If the files haven't been synced, then Steam will ask you which ones to use. It will display a window saying choose either Cloud files or Hard drive files, and will give you a last modified date allowing you to choose the most recent. –  Dave Rook Jan 15 '13 at 14:14
    
Hm, I doubt that it is a local/install issue considering that I tried this from 2 diff user accounts and 2 different machines. –  Zombies Jan 15 '13 at 14:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.