Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 64bit, originally installed on my Samsung Slate 7 (it has 4 GB RAM). Swap is disabled.

Recently Windows has started to show me a low memory warning on about 3GB of RAM usage. I've disabled that warning, using an advice from the Internet. Now programs are failing with typical out of RAM symptoms at 3.2 GB.

Why won't Windows use the last gigabyte of RAM? According Task Manager there's a cache in that gig, but shouldn't Windows replace the cache with apps when demanded?

Note: when swap is enabled, the system freezes very frequently and this is another problem.

share|improve this question
1  
It's not clear what you're saying. What do you mean by "about 3GB of RAM usage"? Is some tool reporting that? If so, what tool? And what precisely is it reporting? What do you mean by "at 3.2 GB"? And what do you mean by "a cache in that gig"? Which panel of task manager is telling you that and what exactly is it saying? (And by the way, you should create a paging file, at least 2GB. Not having it forces Windows to make some very bad decisions, even if it would never use it. You should figure out the freezing problem first.) –  David Schwartz Jan 15 '13 at 16:45
4  
Your video card is probably eating up some of that last GB. –  b.pell Jan 15 '13 at 16:46
    
Windows can’t replace the cache with apps because you’ve disabled swap. –  kinokijuf Jan 15 '13 at 17:11
    
I have 16GB in my Windows 7 box, so Windows 7 certainly does NOT have a 3.2 of 4GB limit. Which means you have a shared graphics device. –  Ramhound Jan 15 '13 at 17:35
1  
@Mokubai the referenced question is an issue with 32-bit OS's while the OP is running a 64-bit architecture. –  KronoS Jan 15 '13 at 19:31

2 Answers 2

up vote 6 down vote accepted

The "missing" RAM is probably allocated to your video card (and possibly other hardware - though usually the video card is what sucks a big chunk of ram).

In fact here it says http://www.samsung.com/us/computer/tablet-pcs/XE700T1A-A03US-specs:

Graphics

Graphic Chip Intel® HD Graphics 3000

Maximum Graphics Memory Shared

My recommendation is to enable swap and insert a SD card (16GB or 32GB) and tell Windows to use readyboost on the SD card. This doesn't magically give you more RAM, but I believe it should help with the freezing.

A reinstall with a store copy may help with your memory situation - I know they like to have a lot of bloat.

Also if the internet (or someone) is telling you to ignore warnings or errors - it's probably the wrong thing to do.

share|improve this answer
    
On a typical computer, an integrated GPU is the only peripheral that shares any significant amount of RAM. (You may be thinking about use of low address space that's significant for 32-bit operating systems. But 64-bit operating systems can use the remapped memory, so the memory isn't taken or lost.) –  David Schwartz Jan 15 '13 at 17:21

The "low memory warning" has nothing directly to do with the amount of RAM that's in use. It has to do with running out of commit limit, which is the maximum possible amount of private pageable address space. The commit limit on a Windows system is size of usable RAM + your pagefile size. If you've disabled the pagefile, as apparently you have, then it's just the size of usable RAM. It doesn't matter how much of the RAM is "in use"; the commit limit (you'll see this on the Task Manager screen) stays the same. If a program's request for private virtual memory, added to the current commit charge (this also is on the TM screen), totals to more than the commit limit, the request for virtual memory will fail, and you get the error popup.

The cure is to enable your pagefile again... or add more RAM, if you can.

n.b.: Windows systems do not "freeze very frequently". I've never disabled my pagefile (except for test and demo purposes) on any Windows NT-family system, going back to the pre-release beta of NT 3.1, and the only times I've ever seen them "freeze very frequently" were due to completely different problems. Re-enable your pagefile and then fix the other problems.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.