Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Ubuntu 9.04 and when I try to mount an SD card with the GUI I have to type sudo mount -o remount,rw /media/disk before I can write anything to the card. Is there a hidden setting to make it mount read-write?

share|improve this question
We could use some diagnostic information. Under System->Administration, there's an application to view the system logs. Watch /var/log/syslog while you insert the card and see if anything comes up. Also, open up Places->Computer, and right-click on your SD card and select Properties. Go to the Volume tab and tell us what filesystem the SD card is. – Ryan Thompson Oct 11 '09 at 2:29
It's FAT32 for compatibility with a Sansa Fuze. It looks like my first solution was correct, but I had corrupted the filesystem again by removing the card too soon. I will think about replacing the card, maybe it has some bad blocks. – joeforker Oct 12 '09 at 13:10
This question, in fact, was the answer to my problem. Hail sudo mount -o remount,rw /media/disk. :D – Bleeding Fingers Jan 7 '14 at 20:13
up vote 5 down vote accepted

I ran sudo fsck -a ... on the offending device. After fixing the file system corruption it mounts read-write. I had the problem again, and fixed it again with fsck. Will have to be more careful about always ejecting properly.

share|improve this answer

i was just looking for this as an eee pc specific problem and came across this:

Open terminal.

type in

cd ..

until you are at your file system level, ie your cd .. just returns to where you are at.

Type in

cd /media

Type in

ls -l

to see if your disk is there, usually labeled as disk. You will see something like:

drwxr-xr-x 3 root root 4096 2008-01-20 09:53 disk

Now you will need to change premissions,

Type in

sudo su

and your password. Type in

chown <your user name> <disk name>


chown user disk

Now type in

ls -l

and you should see the change.

ie: drwxr-xr-x 3 user root 4096 2008-01-20 09:53 disk

share|improve this answer
In my case, the media was mounted read-only, so not even root could write to it. Modern distributions provide a gui to mount removable media in which case it will be writable by the current user. – joeforker Oct 13 '09 at 18:40

Did you check the write protection hard-switch on the sd-card reader adapter? That was the problem for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.