Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Vista-based media center, and two XP-based desktop computers, all on a simple home WLAN network (DSL/WLAN router). The Vista computer can see all other computers and transfer/modify files shared on XP, but my XP computers see only each other and not the Vista computer -- why?

I can ping the Vista computer from the XP computers, using it's IP or even it's machine name ("cinema-pc"), but I can't browse to the vista computer using Windows Explorer (neither by IP nor by name): "Windows cannot find '\cinema-pc'. Check the spelling and try again..."

All three computers are using only the regular built-in Windows firewall software with default settings, and I believe the router sets no restrictions on the internal network.

The Vista computer has shares like \\cinema-pc\audio but even if there were no shares on Vista, I would still expect to be able to see the computer itself.

I've tried every trick I know but can't come up with a reason for this behaviour. How do I fix my network so that I can access my Vista computer from my XP computers?

share|improve this question
    
Update after several days fiddling and testing -- I cannot solve the network problems and every single tip given was tested successfully, yet without solving the matter. As much as I hate reinstalling from scratch, I begin to suspect that I need to reinstall my Vista computer, to see if that helps. Perhaps I'll even downgrade to (ugh!) XP Media Center so I'll at least have the same OS all around. –  Torben Gundtofte-Bruun Oct 14 '09 at 6:57
add comment

3 Answers

up vote 2 down vote accepted

Vista and XP networks, in my experience, are quite incompatible. Interaction might work, or it might not. The network might work correctly today, but not work tomorrow.

The major problem is defining the master browser computer for the network. The article Computer Browser contains a good explanation of the problem, and how to assure that the right computer is elected as the master. If not enough, other articles are easy to google.

The problem to avoid is for your Vista machine to come up and decide that it's the master browser of its own network of one, while the XP computers elect one of themselves as master browser of their own network.

To make the XP machines discoverable by Vista, you should install on them the Link Layer Topology Discovery (LLTD) Responder.

You should think the problem through quite carefully, decide on the correct network architecture and define the right master browser (which you might need to enforce), and try very patiently to make it work correctly.

If everything fails, the last resort is giving all the machines fixed IP addresses and updating the hosts files on your network to contain all the addresses.

EDIT

Check this article : File and Printer Sharing in Windows Vista.

Other points:

  • Workgroup Name of all the computers should be the same.
  • In Vista Network and Sharing:
    Network Discovery: ON (So it can see the other computers)
    Network set to Private (Public is for hotspots, airports, etc)
    File Sharing: ON
    Public Folder Sharing: ON (Vista Public Folder is the same as XP Shared Docs)
    Password Protected: OFF (unless you want to set up identical usernames and passwords on all computers in your Network). If you have it ON, you will be asked for a username and password when you try to access a Vista computer from an XP computer.
  • Run the XP Home Network File and Printer sharing Wizard.
share|improve this answer
    
"quite incompatible" ... a baffling statement about the world's most widespread operating system! But likely true, sadly. I'll check those articles, thanks for the links! –  Torben Gundtofte-Bruun Oct 10 '09 at 17:59
    
Well, maybe "quite incompatible" is a bit strong, but in my experience there are always some surprises in store. But maybe your network is more tightly controlled than our office network and you could manage to get it working once and for ever. –  harrymc Oct 10 '09 at 18:46
    
"To make the XP machines discoverable by Vista" -- my problem is the other way round. Vista can discover the XP machines, but XP can't discover Vista. –  Torben Gundtofte-Bruun Oct 11 '09 at 10:17
    
All the machines must discover each other and elect a master browser. The discovery process can take 15 minutes. Normally Vista should win the election as it's a higher Windows version, unless a server machine takes precedence. The article discusses how to find out which machine(s) think themselves masters. You need to follow the article above step-by-step to correctly setup your network architecture. If you can't manage, see the last part of my answer. –  harrymc Oct 11 '09 at 13:16
    
I've disabled the Computer Browser service on my XP machine. Will report results tomorrow. –  Torben Gundtofte-Bruun Oct 11 '09 at 20:17
show 7 more comments

I have Vista & XP in my office network. We did face a similar issue that we could not Remote Desktop , browse or VNC the vista machines for an XP machine. Turned out that Vista's Firewall was playing spoilsport. Disabling the firewall helped.So in short did you try disabling the firewall (Vista Machine)?

share|improve this answer
    
Firewall off didn't help. Turned it back on for (relative) safety. –  Torben Gundtofte-Bruun Oct 11 '09 at 20:14
add comment

Despite what the other user said, Vista and XP are fully compatible on a network. You just have to fiddle with the settings to get everything shared out properly.

Since you can ping the Vista box by both IP and UNC we know that it's live on the network. What you're running into is something on the Vista PC blocking access to the files and folders. I'd start by checking the network settings on your Vista PC. Try either disabling the firewall or setting the network to Private instead of Public. For more information, try this page from Microsoft. Good luck!

share|improve this answer
    
The LAN is already set to private. The workgroup is the same on both machines. I've tried disabling the firewall but that also didn't solve the issue. What other network settings would be relevant? One hint might be this: in Network and Sharing Center, the heading "file sharing" has "on" and "off" modes but "custom" is displayed. When I select "on" and save, it reverts to "custom". This puzzles me. -- The MS webpage is interesting; I'll check every detail twice to see if I left anything out. –  Torben Gundtofte-Bruun Oct 11 '09 at 10:17
    
Workgroup: no go. Firewall ports open: no go. Firewall off: no go. Next up: the "browser" article in harrymc's post. –  Torben Gundtofte-Bruun Oct 11 '09 at 20:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.