Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Mac died and I needed to reinstall. I tried to restore from my Time Machine backup, but that also crashes for me (no idea why). So I've reinstalled OS X 10.6 (Snow Leopard) and ran all the updates, so I'm on 10.6.8.

I want to get Mountain Lion back (which I'd previously bought from the Mac Store), but I can't run the App Store to get it: When I try to load it I get a message:

You have OS X 10.6.8. The application requires 10.7 or later.

What can I do?

share|improve this question
    
So, you can't run the Mac App Store itself? You got the App Store through System Update, right? –  slhck Jan 15 '13 at 21:46
    
What version of the App Store application are you using? I suspect the version you are using is too new. My copy of Snow Leopard has App Store 1.0.2, and can download Mountain Lion... –  Scot Jan 15 '13 at 21:56
    
I ran the system update to get 10.6.8. That didnt put app store in the usual menu place (under the apple), but I can find it from spotlight. And when I run it, I get the message I described. –  user41270 Jan 15 '13 at 22:03
    
@Scot thanks, how can I tell what version of app store? and can I get the right version somehow? –  user41270 Jan 15 '13 at 22:04

1 Answer 1

App Store should be located at this location:

/Applications/App Store

so, open the Applications folder, select the App Store application, and select "Get Info" under the "File" Command in the Finder. If it is not 1.0.2, or if the App Store app is located elsewhere, I suspect it is misinstalled. Try redownloading the 10.6.8 combo installer, apply it, then retry the App Store...

share|improve this answer
    
Actually, I'd run the combo updater even if the App Store is the right version -- something is weirdly wrong, and installing the combo update has a reasonable chance of fixing it. –  Gordon Davisson Jan 16 '13 at 2:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.