Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed a couple of updates and now my computer won't shut down or install certain updates I thought it might just need some time so have left it while going to bed and it is still stuck on the same update when i get up. So i have tried booting it up in safe mode and a system restore but the same problem still occurs. I have also tried Control Panel\All Control Panel Items\Troubleshooting\Fix problems with windows update, which then says the problem is fixed but updates are still failing to install.

For visual studio service pack 1 update it freezes around half way through instillation. And the same problem occurs with the update for microsoft visual studio 2010 tools for office runtime (kb2796590)

Any suggestions?

Answer

Found out in the end after more update not installing and a couple of programs failing to install it was a problem with the "InstallShield Wizard". Which the only way I was able to fix was through a clean install.

share|improve this question
    
When I had a similar problem with a different update I found it was corrupted files; a fact confirmed by sfc /scanNow. –  Guy Thomas Jan 15 '13 at 22:24
    
I am having the same problem today. WU has been stuck installing the Update for Microsoft Visual Studio 2010 Tools for Office Runtime for about 24 hours. I finally just stopped the installation and it's been trying to stop for about 5 minutes already. –  Joe Philllips Jan 16 '13 at 1:39
    
I've tried the sfc /scannow but it claims everything is fine –  difurious Jan 16 '13 at 17:17

1 Answer 1

Kill the windows update process (it's the one that starts with "wu..."). I had two of them running -- one under the SYSTEM account and one under my own account. I killed the system account process.

It will then say that the update failed and there are X number remaining. You can then start installing them again and it should work better this time.

share|improve this answer
    
I managed to kill it, but if i try and install the update again it just freezes at the same point. I've also tried downloading the update directly from the Microsoft website, and that version freezes as well. –  difurious Jan 16 '13 at 13:49
    
I think my installer was able to skip the update somehow when I killed the process. After doing that, it got stuck on a different update and I had to kill it again. Then it finally started working and I rebooted and finished them all up without issue. It was strange but... when in doubt, do random things until something works. –  Joe Philllips Jan 16 '13 at 17:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.