Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The wireless in my Asus P8Z77-V Pro didn’t work (it’s a new machine, in which I installed Debian Linux 6.0.6, kernel 2.6.32-5-amd64), and since I’m not an advanced user, and knew naught about wireless, I came here for help. But before I could come up with a better description of the problem than “I turn the system on and there’s no wireless in sight!”, I decided to read the “How to ask a question” section, and then I saw the “help vampires” definition, which got me a bit ashamed of myself. So I set off to do my homework (an awful hard one at that), which, to complete the circle, got me back here four days later with a quite different problem — I think. So here it goes:

  1. “find out what the wireless hardware is” — done: Atheros AR9485;

  2. “find out what driver to use with that” — done: ath9k;

  3. “get the driver” — done… well, sort of. It seems that this ath9k driver comes native in Linux since the kernel version 2.6.27 and, therefore, I had it since the beginning.

What else then? Well, I surfed around the net, and learned that I should configure the thing using iwconfig. I tried that but it didn’t work either — this was the output:

 root@balafom:~# iwconfig
 lo        no wireless extensions.

 eth0      no wireless extensions.

 pan0      no wireless extensions.

Then I found the Linux Wireless ath9k page, where there was a list of supported chipsets with the following entry:

AR9485 (>= 2.6.39) 1x1 SB 11n PCIe

I don’t know what all that means, but the parenthesis looked to me as a threatening indication of minimal Linux kernel version to support the beast. So I went on looking for answers, and found the Debian ath9k wiki page. There I found two different chipset support lists, one for squeeze and one for wheezy, and, unfortunately as it turns out, it does seem that my chipset support is not current, but due to be provided only by the latter (kernel 2.6.39?)

Since, as I said, I’m not an advanced Linux user, I don’t feel able to adventure into the land of unstable versions. Would you advise that? Is the kernel 2.6.39 stable enough at this point? Can it be installed and run with the remaining system components and the rest of the software still on their stable current versions?

I started then to gather information about kernels and kernel changes, and found out that the last stable kernel, released last December, was 3.7.2, which got me really confused, because in my distro’s stable release, the kernel is 2.6.32. And, more than that, version 2.6.39 isn’t even listed in kernel.org… So I’m lost now. And how-come there is no support available now for my chipset if the correct driver (ath9k) is already present in my machine? What else is missing? Is it the wrong version? Can it be updated? I really can’t even tell if these questions make any sense at all, and I actually don’t know what would be the intelligent questions to ask right now! And if I can’t organize my questions, I’m stuck and can’t move on on my own…

So, what do you suggest? Remember that I am not a tech guy: I do believe that kernel compilation and such hacks would most certainly above my capabilities…

Well, that’s that. Forgive-me if this help request strays from the ordinary way to ask questions here, and if it’s long and boring — this is my first. After all I’m just a teacher in Literary Theory, trained in narrative, but not in the forum genre.

Thank you all for the patience,
Cassio.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I continued to snoop around and found a solution to my compatibility problem (although I wasn’t able to make it work so far — in the end I’ll describe my attempt). So, here are my answers to the main questions posed above:

  1. It seems the Wheezy is not a good choice at this point, due to the 287 Release-Critical bugs still unfixed by the first week of 2013. And waiting for the release might require patience, because the rate of decrease of such bugs has averaged 18 bugs a week in the last 10 weeks (cf. Debian Project Release-Critical Bug Report for Week 01).

  2. It does also seem that yes, the driver can be updated with no need to rebuild the whole kernel. The approach to drivers is modular, so all that’s needed is to have the appropriate updated, kernel compatible module and load it. That could be a tricky thing, but there are people out there working for the common good, and so there is a back-port of the more recent drivers to older kernels, made available in a bundle called compat-drivers (formerly known as compat-wireless).

Building the module requires the kernel headers to be installed (it took me a while to figure this out). Then it’s a matter of downloading the compat-drivers source, uncompressing it and following the instructions available in the [compat-drivers documentation] (sorry, I wasn't allowed to post a third link). I’m happy I found it out: this looks to me like a complete answer by all accounts — except my own. I’m so much of a newbie that I couldn’t manage to build the module. I did generate a makefile using the driver-select script to specify the ath9k driver, but the make command failed — here is the output (the actual output is in Portuguese, this is my own fallible back-translation into English):

root@balafom:~/build/compat-wireless-3.6.8-1# make –debug=v  
GNU Make 3.81
Copyright (C) 2006  Free Software Foundation, Inc.

This program built for x86_64-pc-linux-gnu
Reading makefile files ...
Reading makefile files `Makefile'...
Updating the final objects...
Considering target file `all'.
 The file `all' doesn’t exist.
  Considering target file `modules'.
   The file `modules' doesn’t exist.
    Considering the target file `/root/build/compat-wireless-3.6.8-1/.compat_autoconf_compat-wireless-v3.6.8-1'.
     Target `/root/build/compat-wireless-3.6.8-1/.compat_autoconf_compat-wireless-v3.6.8-1' prerequisites done.
    Not necessary to reprocess the target file `/root/build/compat-wireless-3.6.8-1/.compat_autoconf_compat-wireless-v3.6.8-1'.
   Target `modules' prerequisites done.
  The target `modules' must be reprocessed.
make -C /lib/modules/2.6.32-5-amd64/build M=/root/build/compat-wireless-3.6.8-1 modules
GNU Make 3.81
Copyright (C) 2006  Free Software Foundation, Inc.

This program built for x86_64-pc-linux-gnu
Reading makefile files ...
Updating the final objects...
Considering target file `modules'.
 The file `all' doesn’t exist.
 Target `modules' prerequisites done.
The target `modules' must be reprocessed.
make[1]: Entering directory `/lib/modules/2.6.32-5-amd64/build'
make[1]: *** No rule to process target `modules'.  Stop.
make[1]: Exiting directory `/lib/modules/2.6.32-5-amd64/build'
make: ** [modules] Error 2

That’s it, then. This is as far as I could go at this point.

share|improve this answer

I have this chipset, and I too had problems with debian. What worked for me was installing Ubuntu, since it ships with a much newer kernel (it is based on Debian). My wireless card is supported out of the box in version 12.04 (long term support release) and in version 12.10. I personally prefer elementary OS, which is based on Ubuntu 12.04. You should decide what desktop environment you want and choose your variant based on that (Ubuntu for Unity, Kubuntu for KDE, Xubuntu for XFCE, Lubuntu for LXDE). These are by no means your only choices, you can also go with Linux Mint (which is also based on Ubuntu) which includes either the Cinnamon or Mate desktops. Best of luck.

share|improve this answer
    
Well, for now I'm gonna stick to Debian. What really troubles me, though, is that I haven't figured out yet how to successfully compile the compat-driver module... There must be something I'm doing wrong, but I haven't been able to figure out just what yet... Have no experience in compiling. –  Cássio Jan 28 '13 at 1:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.