Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Intel 5300 Wireless Card in my new Lenovo ThinkPad T530. Sometimes, when I use the Wireless switch on the side of the computer, when I turn it back on the computer still says that the Wifi is off.

When I run the Intel Diagnostic, it tells me: Software Radio is OFF and gives the following troubleshooting information:

Verify that your WiFi adapter's radio is on. Use the following methods to turn the radio on and off:

  • The hardware switch.
  • The WiFi On/WiFi Off button in the WiFi connection utility main window. See Turn On or Off the Wireless Radio for more information.

So far, the only way I have discovered to resolve the issue is to go into Device Manager and uninstall the card, then Scan for Hardware Changes. However, this loses the passwords of all of the saved Wireless networks, something I'd like to avoid.

I am using the (currently most recent) driver version 15.5.6 on Windows 8 (64-bit).

share|improve this question
    
I often have similar problems with a T530 after undocking. I haven't found a fix, and the fixes you report don't (always) work either. I didn't know of a hardware switch, gotta try flipping that the next time :) –  dancek Apr 29 '13 at 7:47

3 Answers 3

up vote 2 down vote accepted

After playing with it for a few more minutes, I finally figured it out. It appears to be a bug in Windows, where flipping the switch on the computer turns on/off Airplane Mode, but when Airplane Mode turns off, it doesn't flip the Wireless back on.

I found two ways to fix it:

  1. Run the Network Troubleshooter, by right-clicking the Network icon and choosing Troubleshoot Problems. It finds that the problem is that the Wireless is Off and offers to turn it back on.
  2. Open the Change PC Settings "Windows-8-Style-formerly-Metro-Style" app from the charms bar, go to Wireless, and flip the toggle switch:

enter image description here

Neither of these is really a good solution, considering that the problem shouldn't be happening in the first place, but it's better than what I had to do before.


UPDATE (August 2013): While the problem still has not completely gone away, I have noticed that one of the most likely ways to trigger this behavior is flipping the wireless switch while the computer is booting up or resuming from sleep or hibernate. I often use a network cable when at my desk and I used to plug in or unplug the cable and flip the switch immediately when I put the computer down on the desk. Waiting for a minute or two for the machine to resume from sleep has reduced the frequency of the issue.


UPDATE (March 2014): I updated the computer to Windows 8.1 and the issue seems to have gone away.

share|improve this answer

I had a same problem on my hp laptop , so i stop using switch. You can create shortcut of wi-fi adapter on your desktop and then just disable it when want to use enable it , rather then uninstall it every time to fix problem :)

hope it helps .

share|improve this answer
    
Was it with the same (or a similar model) Intel wireless card and/or Windows version, or was it with something else? I'm trying to narrow down the problem, because I have contacts at Intel and Microsoft, but I want to be sure that I know which one has the problem (if either of them) before I waste a valuable contact's time. –  Moshe Katz Jan 16 '13 at 2:33
    
Its similar model Intel Wireless card but experienced same problem. I think drivers or software is problem cos I try Ubuntu distribution on same laptop and i did not have any kind of problems. –  Apoc Jan 16 '13 at 19:52

I had the same problem today, after plugging an ethernet cable in to use a wired connection. My T530 has a Centrino card, so this -might- be apples to oranges, but after much searching around on this machine, I discovered that the Lenovo Internet Connections utility (inside the ThinkVantage Tools Suite) had turned the wifi radio off. One click to turn it back on, everything began working again. I think I might just delete the Lenovo utility.... too nanny-ish for me....

HTH

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.