Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Linux Mint 14 (Cinnamon) in a VirtualBox VM on Windows 8 host using an HP Envy 17" laptop. It seems like it randomly decides to show the workspace selection screen while I'm doing anything from dragging an icon to double clicking on something n the trackpad. This is making this environment unusable though it would be perfect in all other cases.

Where are the settings to disable any motion based gestures on this? I have poured through the settings on this and can't simply find the right thing. I googled it and am not getting any conclusive results as well.

It has occurred while navigating things to build this question so forgive the brevity. I usually would include more details but every other trackpad contact causes this undesirable affect.

If this isn't the right place let me know.

share|improve this question

2 Answers 2

up vote 10 down vote accepted

That happened to me as well (except with a Windows 7 Host). The mouse stopped jumping around after I disabled Mouse Integration in VirtualBox (as per Mint 14 release notes)

If you don't want to disable Mouse Integration, adding the following in the guest ~/.bashrc also helped for me, reducing the mouse jumping (ref):

xinput set-prop "VirtualBox mouse integration" "Coordinate Transformation Matrix" 0.5 0 0 0 0.5 0 0 0 1.0
xinput set-prop "VirtualBox mouse integration" "Coordinate Transformation Matrix" 1.0 0 0 0 1.0 0 0 0 1.0

Or, you can disable the Hot Corner (which causes the workspace selection to show up when your mouse hits a specified corner of the screen) by going to Menu -> Preferences -> Cinnamon Settings -> Hot Corner.

The mouse still jumps around a bit, but at least the workspaces don't keep popping up randomly ;)

share|improve this answer
    
I definitely disabled the hot corner. Not because I really wanted to but because with the cursor jumping it was really a bad feature. I added on your suggestions and I have a totally workable environment. Thanks. –  Rig Apr 15 '13 at 23:38

Actually, the mouse pointer seems to be reset to coordinate (0,0) so if you still like to have the Hot Corner, you can just move it to any other corner, and you will be fine as well. At least that worked for me. I have my Hot Corner in the top right corner now instead.

So the problem seems to be that Virtualbox puts the mouse pointer in position (0,0) for a very short time before restoring it to the position it had in the virtual machine, and that would trigger the Hot Corner if chosen to be located in the top left corner.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.