Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've set autoplay to "Take no action" on all devices and file types in Windows 7, but Windows Media Player 12 seems to completely ignore this. I can't find a setting in any of the media player options either.

How do I prevent Windows Media Player 12 autoplaying CD's?

share|improve this question
add comment

4 Answers

up vote 4 down vote accepted

This is what i found when i googled for this problem, hope this works for you though this registry edit is meant for Windows Media Player 10:

I checked my other machine and found the same behavior described above when previously it did not autoplay a CD when Media Player 10 was open. So I poked around the registry and found that the CDAutoPlay key was set to 1 on both machines under [HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Preferences]. I changed CDAutoPlay to 0 and things are as they were before. Hope this helps others users having the same issue.

Link to the original post

share|improve this answer
    
That does indeed still work in WM12. Thanks. –  Kev Oct 10 '09 at 18:25
add comment

So I poked around the registry and found that the CDAutoPlay key was set to 1 on both machines under [HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Preferences].

On my machine that key was not present, but adding it manually worked. WMP now doesn't start to play the CDs I insert. Annoying feature - kept interrupting what I was already playing.

share|improve this answer
add comment

This solves the problem partially.

Make the following additions in the registry and the playback is not "unrecoverable"

  1. Open Regedit

  2. Go to HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Preferences

  3. Create a DWORD with name "MediaFolderDetectionDepth" and set its value to "0"

  4. Create a DWORD with name "NonMediaCountToAbortMediaFolderDetection" and set its value to "0"

Now, I put in a DVD with some media files, and mp3 playback does not stop. (previously this was stopping the playback)

In case of inserting a DVD, then I had to stop the playback and press "Play Previous List" in the "Now Playing Window"

Restart is not required. (I see that WMP12 is reading the key atleast one time when the drive is inserted). May be my answer is incomplete. If so, someone please help me (I will also work on this)

I hope this was useful to some level.

share|improve this answer
add comment

THis is not a direct answer, but VLC is a great free player. http://www.vlcmediaplayer.info/download/canadanew.html

share|improve this answer
    
Hmm your answer is not in ANY way related to the question. –  Ganesh R. Oct 10 '09 at 18:04
1  
-1 - Sorry Xavier, I asked about WM12 not VLC. If I wanted to know about VLC, which I've used for years, then I would've asked about that instead. –  Kev Oct 10 '09 at 18:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.