Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Although there are no ATM or similar adapters into a PC running Windows 2003 server, two connections named "ATM ELAN Connection" appear in the Network Connections. The related device appears in the Device Manager as "ATM Emulated LAN".

There's no way to remove them: - Within the Device Manager, an error is thrown: "Failed to uninstall the device. The device may be required to boot up the computer" (tried also the removal booting in Safe Mode, same error) - Within the Control Panel->Network connections: "The connection you selected cannot be deleted"

Any idea?

share|improve this question
    
Could be due to an old PCI DSL adapter installed long time a go. Unsure. There may be some garbage left in the registry..... how to safely remove from the registry? –  Riccardo Jan 16 '13 at 11:57

1 Answer 1

up vote 0 down vote accepted

Ok, I have manually and CAREFULLY Removed all instances associated to the adapter in the registry and rebooted! After the reboot the adapter was disappeared from the network connections (finally) but still showing in the Device manager under the hidden devices; selected and deleted; little wait and VOILA' :-) Do not attempt to do so unless you clearly know what you're doing. Bad editing can bring the machine to unrecoverable\unstable mode

EDIT:

How to:

  • Backup your registry

  • In the registry navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network{4D36E972-E325-11CE-BFC1-08002BE10318}

  • Within the key above inspect each subkey (0000,0001, etc) looking for the adapter description in the Connection key (Name string); you will delete the whole key once the steps below are taken;

  • Copy the guid contained in the string pnpInstanceId

  • Delete the whole subkey (000x, etc) as stated before

  • Delete each reference to the annotated guid found in the registry, be careful particularly when editing multi-line strings

  • Reboot

  • Once rebooted, look into the Device Manager, enabling hidden devices and delete the orphaned adpaters, if any left

  • You're done

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.