Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a Windows XP, 64 bit machine, which serves as a build agent for TeamCity, we have Visual Studio 2005, 2008 & 2010 installed. All three installations have all their Just-In-Time debugger options unchecked in the Visual Studio options dialog (Tools > Options > Debugging > Just-In-Time).

The registry setting which is supposed to govern the JIT debugger (HKEY_LOCAL_MACHINE\Software\Microsoft.NETFramework\DbgJITDebugLaunchSetting) has its value set to "1" as per the instructions at http://www.hanselman.com/blog/HowToTurnOffdisableTheNETJITDebuggingDialog.aspx

Despite these settings, whenever a certain build runs on this agent while an RDP session is active (but disconnected), a dialog box appears in the RDP session which states that the JIT debugger is incapable of debugging because the exception is thrown by a newer version of the .Net framework. The build will hang in TeamCity until someone connects to the RDP session to dismiss the dialog box. At this point, TeamCity declares the build a success and for all intents and purposes, it is.

enter image description here

How do I make the JIT debugger stop interfering with the builds?

share|improve this question

2 Answers 2

[HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug]
"Auto"=dword:00000000
share|improve this answer

Disable the JIT option: Open cmd as adminsitrator and type serverWerOptin /disable

Disable the popup: Go to HKLM\Software\Microsoft\Windows\Windows Error Reporting and add a DWORD key called DontShowUI with a value of 1.

share|improve this answer
    
-1 JIT debugging has nothing to do with WER. –  kinokijuf Feb 5 '13 at 9:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.