Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install an e-mail server in my CentOS server. I have installed and configured postfix and bind, but when I send e-mails I still get "root@localhost" and in my e-mail's headers.

I edited /etc/hosts, hostname and /etc/postfix/ but still the same problem.

This is the header I get:

Received: from ( [])
by (Postfix) with ESMTP id C4E093A38009
for <>; Sat, 12 Jan 2013 19:33:26 -0500 (EST)
Received: from (localhost [])
by (Postfix) with ESMTP id 3295E330E907
for <>; Sun, 13 Jan 2013 03:33:26 +0300 (MSK)
Received: (from root@localhost)
by (8.14.4/8.14.4/Submit) id r0D0XQSo003822
for; Sun, 13 Jan 2013 03:33:26 +0300  

How do I remove root@localhost from headers?

share|improve this question
First, can you add the contents of your /etc/postfix/ to the question? Second, what program are you using to send mail? Does it properly fill in the "From" address field? –  Roland Smith Aug 26 '13 at 21:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.