Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using zsh + oh-my-zsh.

How can I make zsh to stop auto-correct for some words?

e.g. When I do make install or sudo apt-get install, it always tries to auto correct install to INSTALL. Can I make it NOT do it?

Thank you.

share|improve this question
up vote 3 down vote accepted

Have you tried using aliases like this?

alias install='nocorrect install'

Or

alias apt-get='nocorrect apt-get'

Alternatively, this more drastic option

unsetopt correct_all
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .