Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am following various tutorials about using Freenode through Tor. I have tried irssi + cap_sasl.pl, and also weechat, which has builtin SASL support.

The connection fails in following way on both clients (irssi & weechat):

freenode     | irc: connecting to server p4fsi4ockecnea7l.onion/6667 via socks5 proxy 127.0.0.1/9050...
freenode     | irc: connected to p4fsi4ockecnea7l.onion/6667 (127.0.0.1)
freenode  -- | asimov.freenode.net (asimov.freenode.net): *** Looking up your hostname...
freenode  -- | asimov.freenode.net (asimov.freenode.net): *** Checking Ident
freenode  -- | asimov.freenode.net (asimov.freenode.net): *** No Ident response
freenode  -- | asimov.freenode.net (asimov.freenode.net): *** Couldn't look up your hostname
freenode  -- | irc: client capability, server supports: account-notify extended-join identify-msg multi-prefix sasl
freenode  -- | irc: client capability, requesting: sasl
freenode  -- | irc: client capability, enabled: sasl
freenode  -- | SASL authentication successful
freenode  -- | asimov.freenode.net (asimov.freenode.net): *** Notice -- You need to identify via SASL to use this server
freenode =!= | Closing Link: gateway/tor-sasl/account (SASL access only)
freenode     | irc: disconnected from server

The same happens on Irssi: "SASL authentication successful", and then the Notice from server & SASL as disconnection reason.

When I changed password to incorrect one, "SASL authentication failed" occured, so the message about successful SASL authentication is apparently meaningful and correct.

So why Freenode disconnects me?

share|improve this question
    
Are you using a registered and verified nickname? If you hop into #freenode we'll help you figure out what's going on. Once we do, we can come back to this question and add the solution. – jbroome Jan 17 '13 at 12:10
    
@jbroome: the varification was the problem – google has put Freenode verification email into Spam folder twice. If you would put your comment as answer, I would maybe accept it? – Prince Jan 17 '13 at 14:31
up vote 4 down vote accepted

Make sure you are using a registered and validated nick. Nickserv would have emailed you a verification email.

For more help, see:

/msg nickserv help register
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .