Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using a dual-monitor setup and in one of the monitors I have a maximized VMWare virtual machine. Everytime the virtual machine's window receives focus it moves the mouse to the center of that monitor. If the virtual machine window is not maximized the mouse doesn't jump.

Some situations where the mouse is moved:

  • A program in the guest OS has focus, and I minimize that window. VMWare gains focus and moves the mouse away.
  • A program in the guest OS has focus, I click on VMWare's toolbar (in the middle of the top edge) to access any of its menus or buttons (like minimize, restore, File menu, etc.) and the mouse jumps to the center of the screen.

Is there a way to configure VMWare to stop doing that? I've looked in all the configuration and setting windows and haven't been able to find anything that helps me.

My host is Windows 7, and I'm using VMWare Player version 4.0.4 build-744019 to use Ubuntu 10.04 as a guest. I have VMware tools installed in the guest, version 8.8.4 build-743747 (according to vmware-toolbox)

share|improve this question
    
Do you have VMWare tools installed on the guest virtual machine? – David Jan 17 '13 at 1:20
    
@David I do have them installed – frozenkoi Jan 17 '13 at 18:32
    
I have this exact same issue. None of the mouse settings (optimize for games, etc) did anything to correct this issue. – Mark Kegel Aug 12 '14 at 16:33

To solve the problem make ScrollLock is off.

share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – JakeGould Sep 3 '15 at 14:41
    
I had the same problem as described and THIS was the solution for me.. – Scott Warren Jun 16 at 2:27

I've just had exactly same problem. I reinstalled VMware tools and it helped. Now I have version 9.6.5.2700074.

To reinstall VMware tools: When Virtual Machine is working go to Player menu -> Manage -> Reinstall VMware Tools.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.