Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am currently trying to install JDK 1.4.2.19 on a completely clean (no other software) Windows XP SP3, which results in the error

Error reading setup initialization file

When doing the same thing on my "cluttered" workspace Windows 7x64, the installation starts fine.

I used the official (yet discontinued) JDK download from Oracle's archives.

How can I debug this behaviour? I see no logfiles anywhere. What do I need to do to get it to work, and why does it work on my workspace computer?

PS: Please don't ask or discuss why I would want to install that old version, it has business reasons that are not the matter of this question.

Edit: I just tried to install the newest Version of the JDK, 7u11, on that same machine. It worked without any problems. Maybe this helps.

Edit 2: I cannot download the Online Installer, as the machine is not to be hooked up to the net for security reasons.

share|improve this question
    
You haven't downloaded the 64 bit installer by accident have you? Hence it works in Win 7 64bit and not XP 32bit? –  Simkill Jan 17 '13 at 9:27
    
No, I downloaded j2sdk-1_4_2_19-windows-i586-p.exe - The offline installer Version. –  Florian Peschka Jan 17 '13 at 9:28
    
Confirmed by hashing that the files on both PCs are exactly the same with no corruption? –  Karan Jan 18 '13 at 18:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.