Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We've been using PuTTY to access a SCO Unix system for some time now and we've recently found the need to use pass-through/slave printing to a client printer attached to the Windows machine accessing the system.

However, this appears to create a print job per line rather than a single print job with every line within. I have heard there's a modified version of PuTTY floating aroudn which handles this type of printing correctly.

Does anyone know of its existance/where to get it or have any other suggestions?

So far I've tried:

  • Multiple drivers
  • Capturing the output on LPT1 and converting it into a single file then printing, unfortunately this was prone to error and would take too much work.
  • Multiple printers
  • Printing to image-based printers and PDF generators

Any help would be greatly appreciated!

EDIT:

I've tried the following clients now, with no change:

  1. KiTTY
  2. Quest PuTTY
  3. AniTa 32
  4. Aljex Terminal
share|improve this question

The cheapest option is probably to ping Simon Tatham, and beg for pass through printing to be included in the next PuTTY release, alternatively you could evaluate a number of the other Windows ssh clients, to see how functional their printing support is e.g.

Tectia Client, AbsoluteTelnet, smartFTP

As a stop gap have you tried this script?

share|improve this answer
    
Pass-through printing is actually included in PuTTY and it does work, it's just that it tends to print 1 line per page rather than a full document. Some printers can interpret the slew of jobs as one page, but others won't. Unfortunately its the "others" that are causing me problems – Daniel Frear Jan 18 '13 at 10:40

I don't know the program inside-out, so I don't know if it is capable for this, but maybe KiTTY is the one you're looking for..

share|improve this answer
    
Gave it a go, unfortunately it exhibits the same problem – Daniel Frear Jan 18 '13 at 10:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .