Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a virtual machine running linux which runs as a guest machine through VM player on my laptop and acts as a server to my application which I am hosting on IBM Webshphere Portal. On the most machine I have added the ip of the guest machine onto my host file as www.vmportal.com.

I am able to ping www.vmportal.com from the host machine and can even access all the same application pages through a browser. The problem comes when I try to create a BitKinex WebDAV connection to the server.

Details of the configuration below:

enter image description here enter image description here

I also tried using port 10039 which gave me: 1/16/2013 1:19:03 PM.173 [ERROR] [1] couldn't connect to www.vmportal.com:10039 => ip: 192.168.10.141, port: 10039; err. code: 0

Using 10032 I then see this in the logs which I really don't understand: enter image description here

Any help in getting this to connect would be greatly appreciated, I've tried everything I can think of, is there any setting etc I need to check on either my host of virtual machine to get this to work?

Thanks Guys

share|improve this question

migrated from stackoverflow.com Jan 17 '13 at 15:14

This question came from our site for professional and enthusiast programmers.

3 Answers 3

I've tried using BitKinex previously with Portal and have had mixed success. I personally use AnyClient and it seems to be more stable when working with Portal.

It does seem thought that you need to add /wps/mycontenthandler/dav/fs-type1 or /wps/mycontenthandler/dav/themelist or /wps/mycontenthandler/dav/skinlist depending on what endpoint your trying to connect to. These are the standard paths to webdav for Portal.

I also remember if you're using BitKinex you may need to add /all to the end of those paths.

Have a look at the first posts of this link for some more discussion on it http://www.ibm.com/developerworks/forums/message.jspa?messageID=14637763

share|improve this answer
    
Thanks for that Nick, yes I made sure to add the trailing / on the address. I tried AnyClient but couldn't seem to get that going either, I tested it out with a number of server credentials that work on BitKinex also. –  JonnyIrving Jan 17 '13 at 13:02

Personally, I prefer BitKinex over AnyClient because of the error logging right there on the main interface.

Nick is right, you've got to add all three locations:
/wps/mycontenthandler/dav/themelist/
/wps/mycontenthandler/dav/skinlist/
/wps/mycontenthandler/dav/fs-type1/

You've also got to use port 10039.

Having said all that, I don't think these are causing your problem. You said that you can access everything on the VM from the IP address, but have you tried port forwarding on the VM under the NAT options? I had a similar problem connecting and the port forwarding solved it for me.

Here's an explanation:
http://www.howtogeek.com/howto/vmware/allow-access-to-a-vmware-virtual-machinenat-from-another-computer/

share|improve this answer
    
I made all those changes an believe I am a bit closer. On my linux VM I ran command "netstat -a | grep :" which returns all the open port listening I guess. for e.g: "tcp 0 0 *:10032 *: LISTEN", "tcp 0 0 :10033 *: LISTEN", "tcp 0 0 :10034 *: LISTEN". I can telnet each of these port from my windows host. How do I get 10039 on that list!? –  JonnyIrving Jan 17 '13 at 17:18
    
You can try running "lokkit" and turning off the firewall and selinux all together. It's a local VM so that shouldn't pose any security threat. Let me know if that helps. –  online_p Jan 18 '13 at 18:20
up vote 0 down vote accepted

I think it's time to put this one to bed, thanks a lot for your suggestions guys. In the end I simply took another copy of the virtual machine and used that. In the new version I was able to WebDAV into the files on port 10039 first time.

Still no idea what the cause of it might be but at least it's working now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.