Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In my home network I have a desktop (ubuntu 12.04 - as a server), laptop (Windows 7 Ultimate x86 for work) and android phone. Since I installed samba3.6.3 with apt-get and configured shares only

I can't resolve correctly the server from my laptop using a domain I bought and configured, no matter the network it's in. I tried the office, some internet cafes and pub networks - it always fails to connect to any service. The problem is only with the laptop. Other computers from any network resolve it correctly and get service they require (ftp, ssh, httpd).

I tried flushing dns cache with ipconfig /flushdns and it emptied the output ipconfig /displaydns with no success.

Tracert does only one hop. Tracing the domain I bought leads directly to the public IP of the server and tracing the local domain leads to the local ip address of the server.

I have zero ideas how this happened. Any suggestions are appreciated, thanks.

share|improve this question

migrated from Jan 17 '13 at 16:22

This question came from our site for professional and enthusiast programmers.

Does your samba server use the same domain name? Your windows computer might be resolving the name via WINS and not via DNS at all... – haimg Jan 17 '13 at 16:29
No, the server has a different local name. Good guess tho. I'm considering reinstall windows and leave it for some linux distro... – user1987620 Jan 18 '13 at 13:10

You must log in to answer this question.

Browse other questions tagged .