Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been having an extremely odd problem with my desktop computer. It's a custom build (not built by me) running windows xp.

Every so often 1 cpu (it's an amd x2) starts maxing out. When I look in the process list it's an svchost using the cpu. I can kill it and nothing closes but the cpu usage goes back to normal. Sometimes when I kill it my taskbar goes to grey and looks like windows 98, but only sometimes. Every time I kill it my sound disappears. I still get system sounds, but no game music. Oddly enough, if I kill it while playing a game, the sound doesn't stop working until after that game is closed. I did have to replace the video card a while back because of a blown cap, but it was nowhere near the sound card (although I'm guessing that may be why the ethernet card directly below the video card no longer works lol).

I've ran virus scans (although my definitions are a bit out of date, but the only files I ran that could have infected it are older than the definitions) and nothing shows up. Hijack This also doesn't find anything.

The computer runs fine otherwise, but considering it doesn't take long for the svchost file to come back and hog, I'm afraid that having that cpu maxed out all the time is going to wear it out, so I'd really like to get this figured out.

Is this some weird undiscovered virus, a hardware problem, or a gremlin? And how do I find out what specifically is using a svchost process? I tried using process explorer but didn't get any useful information as that process didn't have anything to do with sound... and why only game sounds, music, video sounds turn off, windows says no mixer device installed, and yet I still get system sounds?

There is nothing in msconfig, startup, or services that doesn't belong, and nothing was installed or changed around the time that this started (except the video card mentioned above may have been around the same time, but I don't see how the new video card drivers could cause this)

And actually it can't be the sound card, because it still happens when I use a usb sound card.

Also, I finally got smart after a month of this and checked... the windows audio service (or something like that) would get killed when I killed that svchost file and wasn't set to restart after a failure... I changed that and the svchost file causing the problem does NOT come back when the sound comes back... it comes back at a random time... usually within 5-15 minutes of killing the svchost file

share
    
Killing svchost.exe causes you to loose sound, svchost runs essential windows services, do not kill it, try and find out what causes the processor usage to max out –  HackToHell Jan 18 '13 at 4:49
    
@HackToHell How am I supposed to find out what is causing the cpu to max out? That's the problem I have here is trying to find the culprit! And actually scvhost runs non-essential services as well (sound is non-essential) as well as viruses can show up as variations on svchost... and if I need to use that computer I'm sure as heck not going to leave that file overheating my cpu while I do what I need to do... –  krazykat1980 Jan 18 '13 at 5:03
add comment

2 Answers

Look at this article on determining the source service of SVCHOST. It should allow you to track down what service is running amok. Most likely it is your audio service, though. Make sure you have the latest audio drivers for your sound card.

share
    
I'll check out the article... hopefully that will help me with my hunt... I'm not sure why updating the drivers would make a difference when it worked fine for 2 years with that driver and nothing was changed (plus a separate usb sound card does the same thing) –  krazykat1980 Jan 18 '13 at 9:57
add comment

Using msconfig... remove all non-Microsoft services and then reboot. If all is okay, add back services one by one until the problem service is found.

share
    
maybe I should've pointed out I've done all that... –  krazykat1980 Jan 18 '13 at 6:48
2  
what did you find out? –  mdpc Jan 18 '13 at 14:15
add comment

This site is currently not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .