Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having an issue connecting to my dedicated server using samba. The server is a debian (squeeze) box running a samba server, only small modifications have been made to the default config and the only thing extra I have done is added my unix user using smbpasswd.

I can connect and browse the samba server fine using my work connection, but fails as soon as I browse it at home. I am even using the same laptop I do at work so I know it's not an issue with the PC.

Using Wireshark I have been able to see the exact communication between the client/server. First the client sends a TCP SYN packet, on my home connection this includes a "Window scale: 8" option which isn't present on the work connection.

Next on the home connection, the server will send a TCP RST+ACK packet which has the reset cause listed as "Go away, we're not home", this is not present on the work connection.

I am guessing that for some reason my computer is sending out a "Window scale" option on the first packet when I'm on my home connection which is something the server isn't liking.

Why is my computer doing this and how can I fix it (either client-side or server-side)?

share|improve this question
    
Are you using wire connection at both sites or wireless at both? Or are you using wire only at work and wifi at home? –  mnmnc Jan 18 '13 at 13:08
    
I used wired connection and work, and I have tried both wired and wireless at home. Both get the same result. –  asdasd Jan 18 '13 at 13:10
    
Can you try to run tcpdump on dedicated server and trace communication while connecting from work and from home? tcpdump -s0 -l host 10.10.10.1 or host 10.10.10.2 where 10.10.10.1 is home PUBLIC IP and 10.10.10.2 is work PUBLIC IP. –  mnmnc Jan 18 '13 at 13:24
    
Additionally you can try connecting with telnet to samba port form work and from home - since you are receiving RST and communication is not even established there is something wrong on Transport or Network leyer (OSI). –  mnmnc Jan 18 '13 at 13:27
    
@mnmnc I did the dump, but when I take away the overhead of the SSH packets it doesn't capture anything. I've also tried connecting with telnet to port 445 (samba port) and I just get connection refused. –  asdasd Jan 18 '13 at 13:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.