Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here is what I've done:

  1. I created virtual HDD for windows 8
  2. then I installed windows 8.
  3. After clean windows installation I installed virtualbox guest additions as first application.

There was no problem until, I enabled 2d and 3d video acceleration (both at the same time). Windows started well but, when I clicked "X" and selected "send shudown signal" from popup, windows screen went black and started flickering logon screen.

The problem is, it doesn't occur when I disable both video accelerations. Is that glitch of Virtualbox or something I did wrong?

Please explain how to install Windows 8 as guest OS with 2d and 3d video acceleration enabled.

Here is my system configuration

Host OS: Ubuntu 12.10 64 bit Guest OS: Windows 8 Pro 64 bit Virtualbox v: 4.2.6

And Hardware specs:

enter image description here

It's Dell Inspiron 15R (N5110) laptop with GeForce 525m VGA.

By the way, I haven't install any official video driver form my graphics card: it's built-in driver of Ubuntu.

share|improve this question

1 Answer 1

I'm not sure what you hope to achieve by turning on hardware accelerated graphics for the VM when you haven't optimised the host machine.

Just what graphics hardware is the host running? Is it actually up to the job? If, for example, it is an embedded Intel chipset, there is really no point in trying as the hardware doesn't have the muscle to do it.

UPDATE: OK, so the card isn't bad for a laptop card & the laptop is ok, i5, 6GB RAM.

So, install the NVIDIA drivers on the host and make sure that the VM has sufficient RAM and Video RAM assigned before trying again. As long as nothing else is running on the host, you should be able to assign 4GB to the VM and give the Display 256MB.

There is a calculation for minimum VM graphics RAM in the help file for VirtualBox, it depends on the screen size amongst other things.

You could also play with some of the other settings if the above doesn't work. Try changing the Chipset to ICH9. You might also try the I/O APIC though this would require a reinstallation of the guest OS.

share|improve this answer
    
It's Dell Inspiron 15R (N5110) laptop with GeForce 525m VGA. –  Tural Aliyev Jan 19 '13 at 8:12
    
See my updated answer –  Julian Knight Jan 19 '13 at 12:46
1  
Man, you have serious eye problem. First you did not see my VGA's model. Now, where do you see that my ram is 6gb? Can't you see 7.7 GB ram on screenshot? And the most "dangerous" drivers for ubuntu is nvidia. I installed 1 time, whole my system crashed. –  Tural Aliyev Jan 19 '13 at 14:16
    
Well rudeness is not going to get any answers. The standard RAM for that model is 6, I saw the 8 later. I went to the trouble of looking things up for you but perhaps you don't really want help. –  Julian Knight Jan 20 '13 at 11:45
    
Oh, and on one of my systems with an NVidia card, it is the open source driver that crashes the system and has done with every version of Linux for several years. The closed source driver works perfectly. –  Julian Knight Jan 20 '13 at 11:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.