Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can start chromium from a xinit command

xinit /usr/bin/chromium --kiosk www.google.co.uk

And it boots into the browser but it is not using the full width of my screen. The browser appears on the left two thirds of the screen with the right third black. Can it be made to use the full width?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You need to either have your chomium window manually re-sized previously, for which you need to load it once with a proper window manager. Or edit the the file ~/.config/chromium/Default/Preferences (haven't tested it with more than 1 profile) and edit the following section.

  "window_placement": {                                                      
     "bottom": 1080,
     "left": 0,
     "maximized": true,
     "right": 1920,
     "top": 0,
     "work_area_bottom": 1080,
     "work_area_left": 0,
     "work_area_right": 1920,
     "work_area_top": 0
  }

The maximized option may not work, since I suppose you are not using a Window Manager, but you can see that the properties bottom, left, right, top, work_area_bottom, work_area_left, work_area_right and work_area_top, refer to the size and position of the window. So play around with your own screen size and that should work.

share|improve this answer
    
I changed this file to reflect my screen resolution (as the left and right parameters were indeed the size that it is displaying). However when I rebooted and ran the xinit command again the browser opened the same as before. When I took a look at the preferences file again, the parameters had been changed back to what they were before...... It definitely saved correctly as after I saved it I opened it again and the values were still the ones I had changed so it seems it is setting the values on boot-up. –  coolblue2000 Jan 19 '13 at 14:20
    
OK, If I boot the raspberry pi then set the preferences, then run the xinit command it boots to browser in full screen, then when I reboot it stays as full screen! It seems that perhaps chrome was resetting the variables on shut down and as it was already in a partial screen size, it overwrote my settings. Works fine now Thanks –  coolblue2000 Jan 19 '13 at 14:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.