Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'd like the access to remote files by My Network Places (SMB or Samba) was done by wired connection always when it's available. It makes big difference - WiFi G (about 2-3 MB/s) vs Gigabit Ethernet (tens of MB/s).

I use Windows 7 on laptop connected simultaneously to wired and wireless network. The priority of wired network is set to highest as I need sometimes faster transfer than WiFi, to copy big files. It can be checked using "route PRINT" command. Actually it's one network powered by one router, both cards have own different IPs, and from both, network resources are accessable. If the computer was powered on (booted or resumed) with both connections on, SMB works using wired network, as it should be. However, when only WiFi was used for some time and then ethernet cable is connected, SMB still use WiFi. It is needed to turn off wireless connection to achieve faster wired transfer. Routing metric is ok, because web browser traffic use right connection as these are short-living TCP connections. Big downloads from the Internet when stared on WiFi won't switch to wired when cable is connected during download. It's understandable since TCP connection is once set on WiFi. If it will be reconnected, it will use wired then. The case of SMB it different. I power on the computer with WiFi only. Copy some remote small file and now the SMB knows that that remote server is accessible by WiFi. Then connected to Ethernet and don't use SMB even for hours. When I want copy big file from server it still uses slow WiFi, not wired Ethernet.

Is any way to fix it? I emphasize that I don't want to turn off WiFi connection, because I frequently take my laptop somewhere and when I'm back to my desk I reconnect Ethernet cable.

share|improve this question

2 Answers 2

This normally works automatically. I can do this on my own laptop in the same circumstances as yourself. Once the wire is plugged in, the wired network takes preference and the Wi-Fi network is largely ignored.

I wonder if you have tried to do some manual settings and so confused things? You really shouldn't need to mess with this at all under Windows 7/8.

You might want to remove both the wired and wireless networks completely and then reconnect to the networks to see if Windows corrects itself. When reconnecting, maybe try turning off wi-fi and connecting over the wire first and then turning on wifi.

share|improve this answer

On your Windows PC run ipconfig and make a note of the IP address for the Ethernet adapter - it's this that you want to connect to instead of your Wireless IP.

I had the same issue myself connecting to Windows 8 via OSX until I figured it out - now it's much much faster.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.